Help install ssl

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot --apache -d

It produced this output: ssl certificate installed successfully

My web server is (include version): 22.04

The operating system my web server runs on is (include version): ubuntu 22.04

My hosting provider, if applicable, is: idcloudhost

I can login to a root shell on my machine (yes or no, or I don't know): i dont know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):I run it using putty

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @ayyash-u, and welcome to the LE community forum :slight_smile:

What error message do you get?

I can't resolve that name to an IP: can't find Non-existent domain


Certbot failed to authenticate some domain (authenticator : Apache) the certificate authority reported these peoblems :
Domain :
Type : connetion

Hint : the certificate authority failed to verify the temporary Apache configuration changes Made by certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet

Some challenges have failed
Ask for help. See the logfile /var/log/let'sencrypt/let'sencrypt.log or re run certbot with -v for more details

Something like that

Without an IP in DNS, the site can't be accessed from the Internet.


I created a vm on cloudhost id and it's already running, port 80 and 443 are also allowed

I even recorded it on cloudflare

Did you add an A record entry in Cloudflare DNS?

I say not: nameserver = nameserver = can't find Non-existent domain can't find Non-existent domain

That's been done since the creation of the DNS server, here I got the task of making moodle on the second VM, on cloudflare I've added a record type a , name: moodle, ipv4 : IP of my VM, then I save

But you are trying to get a certificate for the name e-learning:


Yes, I followed the tutorial from my lecturer, but it failed, I tried it with and it failed too

Do you own this domain name? Did your lecturer want you to request a certificate for this particular name, or did you want to do it for your own reason?


Basically you need to decide to either use e-learning or moodle as your subdomain, and make necessary amendments to either your DNS or your command line.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.