# Having Trouble installing certs

**URL:** <https://community.letsencrypt.org/t/having-trouble-installing-certs/179500>\
**Category:** Help\
**Created:** [June 15, 2022, 4:59pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500 "2022-06-15T16:59:30Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 4:59pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/1 "2022-06-15T16:59:30Z")

</div>

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. [crt.sh | example.com](https://crt.sh/?q=example.com)), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: captainnemo.icu

I ran this command: `certbot install --cert-name captainnemo.icu`

It produced this output:

```nohighlight
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Deploying certificate
Could not install certificate
Could not automatically find a matching server block for captainnemo.icu. Set the `server_name` directive to use the Nginx installer.

```

My web server is (include version): nginx version: nginx/1.14.2

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Debian 10

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): certbot 1.28.0

* * *

I did go to /etc/nginx/sites-available/default and added my url to `server_name`. I then ran `sudo systemctl reload nginx` and `certbot install --cert-name captainnemo.icu` but got the same error.

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [June 15, 2022, 5:01pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/2 "2022-06-15T17:01:52Z")

</div>

Hi @johnblood, and welcome to the LE community forum 🙂

Please show the outputs of:  
`grep -Eri server_name /etc/nginx`  
`certbot certificates`

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:03pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/3 "2022-06-15T17:03:45Z")

</div>

> [@rg305](#):
>
> grep -Eri server\_name /etc/nginx

Thanks, @rg305

`grep -Eri server_name /etc/nginx` =

```nohighlight
/etc/nginx/fastcgi.conf:fastcgi_param SERVER_NAME $server_name;
/etc/nginx/scgi_params:scgi_param SERVER_NAME $server_name;
/etc/nginx/sites-available/default: server_name www.captainnemo.icu captainnemo.icu_;
/etc/nginx/sites-available/default:# server_name example.com;
/etc/nginx/sites-available/reverse-proxy.conf: server_name localhost;
/etc/nginx/fastcgi_params:fastcgi_param SERVER_NAME $server_name;
/etc/nginx/nginx.conf: # server_names_hash_bucket_size 64;
/etc/nginx/nginx.conf: # server_name_in_redirect off;

```

`certbot certificates` =

```nohighlight
Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Found the following certs:
  Certificate Name: captainnemo.icu
    Serial Number: 31529f08aa31c3397119fac543b1f9cbb9a
    Key Type: RSA
    Domains: captainnemo.icu www.captainnemo.icu
    Expiry Date: 2022-09-11 17:30:55+00:00 (VALID: 88 days)
    Certificate Path: /etc/letsencrypt/live/captainnemo.icu/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/captainnemo.icu/privkey.pem
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

```

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [June 15, 2022, 5:07pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/4 "2022-06-15T17:07:51Z")

</div>

What happened here?:

```nohighlight
/etc/nginx/sites-available/default:     
server_name www.captainnemo.icu captainnemo.icu_;

```

[where did that underscrore come from?]

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:08pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/5 "2022-06-15T17:08:32Z")

</div>

I'm not sure. Do you want me to remove it?

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [June 15, 2022, 5:08pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/6 "2022-06-15T17:08:46Z")

</div>

I would definitely remove it.

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:11pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/7 "2022-06-15T17:11:39Z")

</div>

Removed the `_` , ran the `sudo systemctl reload nginx`, but certs won't install

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [June 15, 2022, 5:12pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/8 "2022-06-15T17:12:56Z")

</div>

Please show the `certbot` log file:  
`/var/log/letsencrypt/letsencrypt.log`

And the file:  
`/etc/nginx/sites-available/default`

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:17pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/9 "2022-06-15T17:17:06Z")

</div>

> [@rg305](#):
>
> /var/log/letsencrypt/letsencrypt.log

```nohighlight
2022-06-15 17:10:42,343:DEBUG:urllib3.connectionpool:http://localhost:None "GET /v2/connections?snap=certbot&interface=content HTTP/1.1" 200 97
2022-06-15 17:10:43,073:DEBUG:certbot._internal.main:certbot version: 1.28.0
2022-06-15 17:10:43,073:DEBUG:certbot._internal.main:Location of certbot entry point: /snap/certbot/2133/bin/certbot
2022-06-15 17:10:43,073:DEBUG:certbot._internal.main:Arguments: ['--cert-name', 'captainnemo.icu', '--preconfigured-renewal']
2022-06-15 17:10:43,073:DEBUG:certbot._internal.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2022-06-15 17:10:43,091:DEBUG:certbot._internal.log:Root logging level set at 30
2022-06-15 17:10:43,093:DEBUG:certbot._internal.plugins.selection:Requested authenticator None and installer None
2022-06-15 17:10:43,106:DEBUG:certbot.plugins.util:Failed to find executable apache2ctl in PATH: /snap/certbot/2133/bin:/snap/certbot/2133/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
2022-06-15 17:10:43,106:DEBUG:certbot._internal.plugins.disco:No installation (PluginEntryPoint#apache): Cannot find Apache executable apache2ctl
Traceback (most recent call last):
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/plugins/disco.py", line 160, in prepare
    self._initialized.prepare()
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_apache/_internal/configurator.py", line 347, in prepare
    self._verify_exe_availability(self.options.ctl)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_apache/_internal/configurator.py", line 468, in _verify_exe_availability
    raise errors.NoInstallationError(
certbot.errors.NoInstallationError: Cannot find Apache executable apache2ctl
2022-06-15 17:10:43,275:DEBUG:certbot._internal.plugins.selection:Single candidate plugin: * nginx
Description: Nginx Web Server plugin
Interfaces: Installer, Authenticator, Plugin
Entry point: nginx = certbot_nginx._internal.configurator:NginxConfigurator
Initialized: <certbot_nginx._internal.configurator.NginxConfigurator object at 0x7f0bcef61610>
Prep: True
2022-06-15 17:10:43,276:DEBUG:certbot._internal.plugins.selection:Selected authenticator None and installer <certbot_nginx._internal.configurator.NginxConfigurator object at 0x7f0bcef61610>
2022-06-15 17:10:43,276:INFO:certbot._internal.plugins.selection:Plugins selected: Authenticator None, Installer nginx
2022-06-15 17:10:43,281:DEBUG:certbot._internal.display.obj:Notifying user: Deploying certificate
2022-06-15 17:10:43,286:DEBUG:certbot._internal.error_handler:Encountered exception:
Traceback (most recent call last):
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/client.py", line 609, in deploy_certificate
    self.installer.deploy_cert(
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 240, in deploy_cert
    vhosts = self.choose_vhosts(domain, create_if_no_match=True)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 349, in choose_vhosts
    vhosts = [self._vhost_from_duplicated_default(target_name, True,
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 398, in _vhost_from_duplicated_default
    default_vhost = self._get_default_vhost(domain, allow_port_mismatch, port)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 436, in _get_default_vhost
    raise errors.MisconfigurationError("Could not automatically find a matching server "
certbot.errors.MisconfigurationError: Could not automatically find a matching server block for captainnemo.icu. Set the `server_name` directive to use the Nginx installer.

2022-06-15 17:10:43,286:DEBUG:certbot._internal.error_handler:Calling registered functions
2022-06-15 17:10:43,412:DEBUG:certbot._internal.display.obj:Notifying user: Could not install certificate
2022-06-15 17:10:43,413:DEBUG:certbot._internal.log:Exiting abnormally:
Traceback (most recent call last):
  File "/snap/certbot/2133/bin/certbot", line 8, in <module>
    sys.exit(main())
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/main.py", line 19, in main
    return internal_main.main(cli_args)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/main.py", line 1744, in main
    return config.func(config, plugins)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/main.py", line 1101, in install
    _install_cert(config, le_client, domains)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/main.py", line 1049, in _install_cert
    le_client.deploy_certificate(domains, path_provider.key_path, path_provider.cert_path,
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot/_internal/client.py", line 609, in deploy_certificate
    self.installer.deploy_cert(
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 240, in deploy_cert
    vhosts = self.choose_vhosts(domain, create_if_no_match=True)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 398, in _vhost_from_duplicated_default
    default_vhost = self._get_default_vhost(domain, allow_port_mismatch, port)
  File "/snap/certbot/2133/lib/python3.8/site-packages/certbot_nginx/_internal/configurator.py", line 436, in _get_default_vhost
    raise errors.MisconfigurationError("Could not automatically find a matching server "
certbot.errors.MisconfigurationError: Could not automatically find a matching server block for captainnemo.icu. Set the `server_name` directive to use the Nginx installer.
2022-06-15 17:10:43,414:ERROR:certbot._internal.log:Could not automatically find a matching server block for captainnemo.icu. Set the `server_name` directive to use the Nginx installer.

```

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:17pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/10 "2022-06-15T17:17:51Z")

</div>

> [@rg305](#):
>
> /etc/nginx/sites-available/default

```nohighlight
##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# https://www.nginx.com/resources/wiki/start/
# https://www.nginx.com/resources/wiki/start/topics/tutorials/config_pitfalls/
# https://wiki.debian.org/Nginx/DirectoryStructure
#
# In most cases, administrators will remove this file from sites-enabled/ and
# leave it as reference inside of sites-available where it will continue to be
# updated by the nginx packaging team.
#
# This file will automatically load configuration files provided by other
# applications, such as Drupal or Wordpress. These applications will be made
# available underneath a path with that package name, such as /drupal8.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
        listen 80 default_server;
        listen [::]:80 default_server;

        # SSL configuration
        #
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
        #
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html;

        server_name www.captainnemo.icu captainnemo.icu;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;
        }

        # pass PHP scripts to FastCGI server
        #
        #location ~ \.php$ {
        # include snippets/fastcgi-php.conf;
        #
        # # With php-fpm (or other unix sockets):
        # fastcgi_pass unix:/run/php/php7.3-fpm.sock;
        # # With php-cgi (or other tcp sockets):
        # fastcgi_pass 127.0.0.1:9000;
        #}

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        # deny all;
        #}
}

# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
# listen 80;
# listen [::]:80;
#
# server_name example.com;
#
# root /var/www/example.com;
# index index.html;
#
# location / {
# try_files $uri $uri/ =404;
# }
#}

```

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 5:22pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/11 "2022-06-15T17:22:13Z")

</div>

By the way, I'm using this to host Gitea.

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [June 15, 2022, 5:58pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/13 "2022-06-15T17:58:16Z")

</div>

```nohighlight
Could not automatically find a matching server block for captainnemo.icu. Set the `server_name` directive to use the Nginx installer.

```

Please show:  
`sudo nginx -T`

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 6:10pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/14 "2022-06-15T18:10:31Z")

</div>

> [@rg305](#):
>
> sudo nginx -T

```nohighlight
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
# configuration file /etc/nginx/nginx.conf:
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
        # SSL Settings
        ##

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

        ##
        # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}

#mail {
# # See sample authentication script at:
# # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
# # auth_http localhost/auth.php;
# # pop3_capabilities "TOP" "USER";
# # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
# server {
# listen localhost:110;
# protocol pop3;
# proxy on;
# }
#
# server {
# listen localhost:143;
# protocol imap;
# proxy on;
# }
#}

# configuration file /etc/nginx/modules-enabled/50-mod-http-auth-pam.conf:
load_module modules/ngx_http_auth_pam_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-dav-ext.conf:
load_module modules/ngx_http_dav_ext_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-echo.conf:
load_module modules/ngx_http_echo_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-geoip.conf:
load_module modules/ngx_http_geoip_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-image-filter.conf:
load_module modules/ngx_http_image_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-subs-filter.conf:
load_module modules/ngx_http_subs_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-upstream-fair.conf:
load_module modules/ngx_http_upstream_fair_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-http-xslt-filter.conf:
load_module modules/ngx_http_xslt_filter_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-mail.conf:
load_module modules/ngx_mail_module.so;

# configuration file /etc/nginx/modules-enabled/50-mod-stream.conf:
load_module modules/ngx_stream_module.so;

# configuration file /etc/nginx/mime.types:

types {
    text/html html htm shtml;
    text/css css;
    text/xml xml;
    image/gif gif;
    image/jpeg jpeg jpg;
    application/javascript js;
    application/atom+xml atom;
    application/rss+xml rss;

    text/mathml mml;
    text/plain txt;
    text/vnd.sun.j2me.app-descriptor jad;
    text/vnd.wap.wml wml;
    text/x-component htc;

    image/png png;
    image/tiff tif tiff;
    image/vnd.wap.wbmp wbmp;
    image/x-icon ico;
    image/x-jng jng;
    image/x-ms-bmp bmp;
    image/svg+xml svg svgz;
    image/webp webp;

    application/font-woff woff;
    application/java-archive jar war ear;
    application/json json;
    application/mac-binhex40 hqx;
    application/msword doc;
    application/pdf pdf;
    application/postscript ps eps ai;
    application/rtf rtf;
    application/vnd.apple.mpegurl m3u8;
    application/vnd.ms-excel xls;
    application/vnd.ms-fontobject eot;
    application/vnd.ms-powerpoint ppt;
    application/vnd.wap.wmlc wmlc;
    application/vnd.google-earth.kml+xml kml;
    application/vnd.google-earth.kmz kmz;
    application/x-7z-compressed 7z;
    application/x-cocoa cco;
    application/x-java-archive-diff jardiff;
    application/x-java-jnlp-file jnlp;
    application/x-makeself run;
    application/x-perl pl pm;
    application/x-pilot prc pdb;
    application/x-rar-compressed rar;
    application/x-redhat-package-manager rpm;
    application/x-sea sea;
    application/x-shockwave-flash swf;
    application/x-stuffit sit;
    application/x-tcl tcl tk;
    application/x-x509-ca-cert der pem crt;
    application/x-xpinstall xpi;
    application/xhtml+xml xhtml;
    application/xspf+xml xspf;
    application/zip zip;

    application/octet-stream bin exe dll;
    application/octet-stream deb;
    application/octet-stream dmg;
    application/octet-stream iso img;
    application/octet-stream msi msp msm;

    application/vnd.openxmlformats-officedocument.wordprocessingml.document docx;
    application/vnd.openxmlformats-officedocument.spreadsheetml.sheet xlsx;
    application/vnd.openxmlformats-officedocument.presentationml.presentation pptx;

    audio/midi mid midi kar;
    audio/mpeg mp3;
    audio/ogg ogg;
    audio/x-m4a m4a;
    audio/x-realaudio ra;

    video/3gpp 3gpp 3gp;
    video/mp2t ts;
    video/mp4 mp4;
    video/mpeg mpeg mpg;
    video/quicktime mov;
    video/webm webm;
    video/x-flv flv;
    video/x-m4v m4v;
    video/x-mng mng;
    video/x-ms-asf asx asf;
    video/x-ms-wmv wmv;
    video/x-msvideo avi;
}

# configuration file /etc/nginx/sites-enabled/reverse-proxy.conf:
server {
        listen 80;
        listen [::]:80;
        server_name localhost;

        access_log /var/log/nginx/reverse-access.log;
        error_log /var/log/nginx/reverse-error.log;

        location / {
                    proxy_pass http://localhost:3000;
  }
}

```

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [June 15, 2022, 6:21pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/15 "2022-06-15T18:21:58Z")

</div>

`/sites-available/` is not the same as `/sites-enabled/`.

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 6:26pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/16 "2022-06-15T18:26:27Z")

</div>

So, do I need to add my url to `/sites-enabled/` ? I read through a bunch of stuff prior to creating this threat and got confused.

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [June 15, 2022, 6:34pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/17 "2022-06-15T18:34:44Z")

</div>

> [@johnblood](#):
>
> So, do I need to add my url to `/sites-enabled/` ?

Yes. Only the configuration files from that directory are included, not those from the "available" directory.

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 6:36pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/18 "2022-06-15T18:36:54Z")

</div>

Do I need to reset my changes in `/sites-available/`?

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [June 15, 2022, 6:43pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/19 "2022-06-15T18:43:31Z")

</div>

No, that underscore was incorrect anyway. I believe nginx _can_ make use of the underscore in `server_name`, but AFAIK only as a "separate" entity (i.e.: not "stuck" to another hostname). It does not have any use in your situation I believe.

---

<div class="post-metadata">

**Author:** ![johnblood](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/johnblood/32/61471_2.png) [@johnblood](https://community.letsencrypt.org/u/johnblood)\
**Post date:** [June 15, 2022, 6:48pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/20 "2022-06-15T18:48:24Z")

</div>

So, do I need to edit `/etc/nginx/sites-enabled/reverse-proxy.conf` ?

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [June 15, 2022, 6:52pm UTC](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500/21 "2022-06-15T18:52:10Z")

</div>

Is `reverse-proxy.conf` even in `/sites-enabled/`? Because from your previous grep for `server_name`, it was only in `/sites-available/`.

In any case, the way some nginx installations work are that all _available_ configuration files are in `/sites-enabled/` and if the sysop wants to _enable_ one of those, the configuration files from `/sites-available/` are **symlinked into** `/sites-enabled/`.

I have no idea what `reverse-proxy.conf` does, so I also have no idea if it should be enabled or not.

[Next page](https://community.letsencrypt.org/t/having-trouble-installing-certs/179500.md?page=2)
