Hamburger icon Menu Fails

I am looking for a secured Hamburger icon menu
Right now,
I use the Hamburger icon menu:
http://www.dynamicdrive.com/dynamicindex1/hamburger-icon-menu.htm for domains under greenfees.world

My domain is:greenfees.world

I ran this command: Click on hamburger

It produced this output: Nothing

My web server is (AWS Debian 9.9):

The operating system my web server runs on is (Debian 9.9):

My hosting provider, if applicable, is:AWS

I can login to a root shell on my machine yes

The version of my client is : certbot 0.28.0

1 Like

See all those resources in your source code that begin with http:// ?

You need to use the secure versions (https://) of them, because browsers refuse to load insecure content on secure (HTTPS) pages.

This is also known as a “mixed content” issue.

Specific to your hamburger menu - your browser is refusing to load the insecure jQuery resource, which your menu relies on to work.

Try using https://www.whynopadlock.com/ to identify the problematic insecure resources.

1 Like

Thanks,
Is it possible to find a jQuery source that is secured?
I know it is a library and open source.

Another option:
Also is it possible to copy and paste the jQuery resource file and put it under my secured https tree. The call it …

I am wondering if I can treat the jQuery as Java …
Never used jQuery before…

Thanks again!!

1 Like

Fixing these issues is usually just a matter of using https:// instead of http://, as most resources will be available over HTTPS.

So you’d instead use https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js.

Rinse and repeat for any other insecure content you have.

Yes, you can do that too.

1 Like

OK…I’ll give it a go…Thanks very much.
I did call up https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js in a browser so it is certainly there …
Thanks again…
Ger

1 Like

Perfection… It works …Thank you very much!
Ger

2 Likes

Hi @TheBruce

there is explicit mixed content you should fix ( https://check-your-website.server-daten.de/?q=greenfees.world#html-content ):

link
	shortcut icon
	http://www.greenfees.online/fave/greenfees.ico
	
	
	1
	http-link, change to https

It’s only one link - element, but that breaks your https.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.