Green padlock not shown on BigBlueButton conference system


#1

We have in IAI a Server running BigBlueButton and a server running a Frontend for this BigBlueButton.
Both running nginx.
So the one https://bbb.iai.int shows the demo page, the login, perfectly with the green padlock. As soon as I click on the login button I get an error and before I set up https there was no error, but I suppose this has to do with bigbluebutton and not with the Let’sencrypt certificate.
The other one, https://conference.iai.int, works perfectly well through the whole process of creating conferences and everything else, continuously showing the green padlock.
Then again, as soon as a invitation mail for a conference is received and one clicks on the link, one gets to the https://bbb.iai.int/whateverconference...and it works, but does not show the green padlock.
What am I overseeing? Where did I forget a step in configuring or in using the command certonly?

If anyone could show me the right way to get things solved I’ll appreciate it very much.
Regards,
Alejandro


#2

About a year ago, the API demos were updated to work with HTTPS. How up2date is your BBB?


#3

It looks like your certificates are valid. The most common reason for the padlock going away when certificates are valid is mixed content. After visiting a conference link, open your browser’s developer console to look for any warning messages about mixed content.

If you’d like to create a “throwaway” conference invite to which you could share the link, we might be able to take a look and help debug.


#4

I have here the bbb 1.1 version, so we are up-to-date.
Problem got solved. The programmers of our GUI had to do a lot of updates in the gems and so on…could not do them myself because I have no access to the code…and after this problems THAT is being solved too!


#5

I had no chance of opening a developers console… the programmers who made our GUI are an external enterprise and gave me no access to the code…They solved the problem updating a lot of gems, and they will now give me access so that I can do troubleshooting on my own. They will get the jobs of mayor upgrades, but everything else will rely on me. Problem solved.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.