Getting "Internal Error" from NPM when trying to assign certificate!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: bigpigmart.com

I ran this command: I just clicked "request a new SSL Certificate" in Nginx Proxy Manager

It produced this output: [Express ] › :warning: warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-28" --agree-tos --authenticator webroot --email "MYEMAIL@gmail.com" --preferred-challenges "dns,http" --domains "bigpigmart.com"

My web server is (include version): uhm Nginx Latest?? I guess

The operating system my web server runs on is (include version): WSL Linux/Ubuntu

My hosting provider, if applicable, is: Self hosted

I can login to a root shell on my machine (yes or no, or I don't know): I don't know, probably?

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Probably not?

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): i dont even know

I must mention that I had it issue certificates to bigpigmart.com before but I deleted the previous Docker container/image and made a fresh one.... I don't know if I'm missing something or what.

I seriously don't know what I'm really doing but I am trying to learn to host my own website!!

Hi @dragonhunter, and welcome to the LE community forum :slight_smile:

NPM is not easy to troubleshoot.
Maybe we can find a clue about what has gone wrong in the file:
/var/log/letsencrypt/letsencrypt.log

4 Likes


Thank you for the welcome!!

I am very eager to hear what you have to say about my situation.

I currently cannot find "/var/log/letsencrypt/letsencrypt.log"
I tried to look through the WSL files through my Host Computer directory.
Would I need to access this location through the Ubuntu shell or whatever its called?

Try [within the Ubuntu shell]:
find / -name letsencrypt.log

4 Likes

in the ubuntu shell right?

1 Like

CLI
SSH
PuTTY
Linux prompt

[many names for it]

4 Likes

I think its searching. was i supposed to run it in sudo?

sudo shouldn't be required [to find it].

But do that if it can't find it.

4 Likes

so is it normal for all the denied permissions?

yes, those are just paths that a regular user shouldn't have access to.

4 Likes

I believe it is still searching... should I stop it and run sudo for it? if so, how would I stop it? I don't mind waiting patiently if you think it will still find it.

It finished. I don't believe it found it :frowning:

its currently searching with sudo

1 Like

Sorry, I'm "multitasking", so it takes me a few minutes to get back to this topic.

[note: "multitasking" means drinking :beer: with both hands! - LOL]

5 Likes

no problem, you have no idea how much I value the time you're giving me right now.
this is all I got when I used sudo
I think my shells are already running on Admin by default

1 Like

Maybe the details of what we are looking for are in this file:

Let's have a look at it.

4 Likes

Does that say "/mnt/c/Windows/..." ?

I totally missed the:

...entering new territory...
LOL

5 Likes

Sure does say that. Is that a horrible thing?

I wouldn't say horrible.
I would say ... different.
Not every day you see a Macintosh running Windows OR Windows running Linux ...

4 Likes

wtf Macintosh.. I thought that was short for Mount