Getting error "The requested webroot plugin does not appear to be installed"


#1

Hi,

I’m trying to set up certbot on my site. I’ve followed the instructions here to download certbot-auto and make it executable. After this, ./certbot-auto runs (though it produces some deprecation warnings for python 2.6) and displays the help text.

When I run ./certbot-auto certonly --webroot -w /path/to/webroot/ -d example.com, I get an error saying “letsencrypt: error: unrecognized arguments: -w /path/to/webroot/”. When I try just ./certbot-auto certonly --webroot, I get the error: The requested webroot plugin does not appear to be installed. When I run ./certbot-auto plugins I get back No plugins.

I’m confused, since the docs don’t mention anything about having to explicitly install plugins for certbot. Am I doing something wrong?


#2

Never mind - I’ve fixed this.

I just had a machine with old dependencies that hadn’t been updated. I updated everything on the machine, and certbot works now. I’m not sure what specifically fixed the issue, but I suspect it was upgrading python that fixed it.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.