Getting Certificate with incorrect domain

I’ve tried to use the FreePBX GUI, on a centos 7 Server hosted on VULTR… I have no problem creating lets encrypt Certificate or renewing it, but the Certificate returns with wrong domain… I’ve verified my domain krm-pbx-7.kennymais.com resolves correcty and the reverse DNS Lookup (by ip) returns the correct domain as well…

However Lets encrypt continues to issue the certificate to vultr.com

I have my primary domain on a hosted server and the PBX is configured as a subdomain, in the DNS Configuration but resides on a VUltr Server… The DNS Resolves correctly on both… Ive also tried this on two completely diferent VULTR Machines with diferent IP address, both doing the same thing

My Primary domain is: kennymais.com

I ran this command:

It produced this output:

My web server is (include version): Apache 2.4.6

The operating system my web server runs on is (include version): centos 7

My hosting provider, if applicable, is: vultr

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): FreePBX Web GUI

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Hi @kennymais

you have not only to create the certificate, you have to install it.

Certificate creation has worked - https://check-your-website.server-daten.de/?q=krm-pbx-7.kennymais.com#ct-logs

Issuer not before not after Domain names LE-Duplicate next LE
ZeroSSL RSA Domain Secure Site CA 2020-07-10 2020-10-09 krm-pbx-7.kennymais.com
1 entries
Let’s Encrypt Authority X3 2020-07-10 2020-10-08 krm-pbx-7.kennymais.com
1 entries duplicate nr. 1

There is a Letsencrypt certificate.

Now install it - read

https://www.freepbxhosting.com/blog/freepbx-ssl-lets-encrypt/

Don’t install it directly, that may not work if you use a control panel that manages your vHosts.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.