Getting cert used to work, now failing (centos 7, nginx)


#1

Last winter, I successfully got a number of certs on this particular server. I hadn’t needed another cert for a while, but just tried yesterday and it failed.

I ran the same command I used to:

./letsencrypt-auto certonly -a manual -d contracorners.com -d www.contracorners.com --server https://acme-v01.api.letsencrypt.org/directory --agree-dev-preview

And it displayed:

Updating letsencrypt and virtual environment dependencies.....

for a while, then exited with an error:

Command "/path/.local/share/letsencrypt/bin/python2.7 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-I8D0qh/cryptography/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-uH6TeV-record/install-record.txt --single-version-externally-managed --compile --install-headers /path/.local/share/letsencrypt/include/site/python2.7/cryptography" failed with error code 1 in /tmp/pip-build-I8D0qh/cryptography/

Has something fundamentally changed with how to get certs? When looking at the “getting started” link, I now see “certbot” as a suggested solution, which I don’t remember seeing from last winter. Should I start using that? Will that cause a problem with the certs and other software I’ve already gotten installed?

Anyway, how can I move forward?

(I also did a letsencrypt-auto renew -nvv --standalone command, and it said everything was up to date, but I’m pretty sure that it’s time for at least a couple of them to need to be renewed. I don’t know if that is related or another topic.)


#2

I tried the same command again and it worked this time. I’m not sure what happened the first time.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.