Getting a 500 when requesting certificates

Hello!

I’ve been having a strange problem when trying to generate a SAN certificate. I’ve run into similar issues in the past, but every-time it eventually worked… seems like this is not the case.

My domain is:
app.publica.la and 85 other domains, requesting as a single SAN certificate

I ran this command:
I generate the certificates through https://forge.laravel.com/ so I’m not sure about the commands they run, I’ve already asked about more information to their support team and will add here once I know more.

It produced this output:
I’ve been trying to issue a new certificate since Friday last week, here we have part of the timeline since August 29: Screen Shot 2020-08-31 at 20.49.58|690x483
Had a couple of DNS problems, which I assume are related to the issues of August 30.
But also received some 500 errors like the following:

And we’ve now received a 429 from the amount of attempts: Screen Shot 2020-08-31 at 20.55.40|690x325

My web server is (include version): nginx/1.15.6

The operating system my web server runs on is (include version): Ubuntu 18.04.1 LTS

My hosting provider, if applicable, is: VM in Google Compute Engine managed through https://forge.laravel.com/

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
https://forge.laravel.com/

Any help will be more than welcome, anything else I can do to provide more information just tell me.

Thanks a lot!

All of the 500s are capacity problems with Let’s Encrypt that you can’t do anything about. But they should be intermittent at worst, meaning that multiple attempts should succeed.

This is not from the number of attempts, but in fact from the number of successfully issued certificates: https://tools.letsdebug.net/cert-search?m=domain&q=app.publica.la&d=168

You can see that 5 duplicate certificates with that large number of SANs have been issued this week (the latest as recently as 11 hours ago).

Do you not see any of those in Laravel Forge?

2 Likes

Thanks _az, that’s very useful!

I’ve contacted Forge support again with this new information, will come back here once they reply.