Get cert at VPS

My domain is: azqwrty.cf

I ran this command:
sudo certbot certonly --apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):

And in the end:

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: mydomain.gq
   Type:   dns
   Detail: No valid IP addresses found for mydomain.gq

My web server is (include version): Apache2

The operating system my web server runs on is (include version): ubuntu 20.04

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): sudo certbot certonly --apache

My config at /etc/apache2/sites-available/azqwrty.cf.conf is:
<VirtualHost *:80>
ServerAdmin admin@azqwrty.cf
ServerName azqwrty.cf
ServerAlias www.azqwrty.cf
DocumentRoot /var/www/html/myfolder
ErrorLog {APACHE_LOG_DIR}/error.log CustomLog {APACHE_LOG_DIR}/access.log combined

My domain provider is freenom and my settings:
Name: www Type: A TTL: 3600 TARGET: myip
Name: Type: A TTL: 3600 TARGET: myip.server
Unfortunately it is forbidden to tune @ name there.

Can you confirm what domain name you are trying to use?
From your description, you want to generate a certificate for azqwrty.cf; however, the error message claims you are trying to generate a certificate for mydomain.gq.

You have placed the configuration file into sites-available, but are you sure you’ve created a sym link from sites-available to sites-enabled? You might need to make that link to have apache read that directory.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.