Generating new certs seems to try old challenges


#1

I have successfully generated a few certs in the past but hadn’t saved the challenge data on my host. I cleaned out my client and tried to create from scratch but it keeps trying to re-connect to my host (hosted on S3 through CloudFront) to read the old challenges. How do I force it to try from scratch (or find out my old challenge info so I can re-upload it)?

Command I’m running is:

$ sudo certbot-auto certonly --standalone --standalone-supported-challenges http-01 -d my-domain

Gives me errors saying it can’t find the challenge info on the host at the URL it had previously wanted them at when I set it up (which is understandable as I deleted that after getting the cert, thought it was a one-off thing).


#2

That shouldn’t happen. Can you re-run the command with -vvvvv and post the logs from /var/log/letsencrypt?


#3

So if I run:

$ sudo certbot-auto certonly --manual -d my-domain

Then it works fine.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.