Generated certificate not valid

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot certonly -v --manual --manual-public-ip-logging-ok --email --agree-tos --domain --rsa-key-size 2048 --config-dir .jojo --work-dir .jojo --logs-dir .jojo

It produced this output:
Saving debug log to /Users/sam/.jojo/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Certificate is due for renewal, auto-renewing...
Renewing an existing certificate for
Performing the following challenges:
http-01 challenge for

Create a file containing just this data:


And make it available on your web server at this URL:

Press Enter to Continue
Waiting for verification...
Cleaning up challenges

Successfully received certificate.
Certificate is saved at: /Users/sam/.jojo/live/
Key is saved at: /Users/sam/.jojo/live/
This certificate expires on 2023-09-07.
These files will be updated when the certificate renews.


  • This certificate will not be renewed automatically. Autorenewal of --manual certificates requires the use of an authentication hook script (--manual-auth-hook) but one was not provided. To renew this certificate, repeat this same certbot command before the certificate's expiry date.

If you like Certbot, please consider supporting our work by:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
A Small Orange shared hosting service

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
yes, cpanel 94.0.25. Using "SSL/TLS Status" menu, viewing existing certificate and selecting upgrade. Copying fullchain.pem to "Certificate (CRT)" results in "The certificate is not valid".

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 2.3.0 installed using brew on a Mac; upgraded to 2.6.0 with the same result, less the website challenge and an indication that --manual-public-ip-logging-ok was no longer required.

I'm just not sure where to go to next given I've followed this process before and not had issues. Any help gratefully received. I'm sure I've done something simple wrong...


Your website currently already has a Let's Encrypt certificate installed (ECDSA instead of RSA). So it might be the actions you're currently taking with Certbot are not required at all. Perhaps your hosting provider already has taken care of the certificate part.

However, there are some issues:


Thanks for the help. The ECDSA certificate was generated using the same process I thought:

Domains: *
Issuer: Let's Encrypt
Key: ECDSA, P-256/prime256v1 (02f18d85 …)
Expiration: Jun 10, 2023 11:18:43 PM

I'll try and sort the http redirect. By mixed content, do you mean both encrypted and not?

1 Like

Referring to http:// URLs from a website loaded through HTTPS (https://). See e.g.



So should be trying to generate an RSA certificate?

Apparently because I am not auto-renewing certificates under the current settings I cannot redirect http to https.

Shouldn't matter.


One thing should not have anything to do with the other.
If the site serves both [HTTP and HTTPS], then it should be able to redirect the HTTP To HTTPS.


I thought that as well, but apparently the server is not configured to redirect. A decision by the hosting company I assume.

Both are being handled by WordPress.
If you can control that [for your site], then you should be able to have it redirect HTTP to HTTPS for you.


Thanks! Will check that out.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.