FreePBX Invalid Cert Date

Cert says I still have over 50 days, but when I try accessing via browser I get ERR_CERT_DATE_INVALID saying it expired on March 7th.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: voip.groovytek.com

I ran this command: https://voip.groovytek.com

It produced this output: NET::ERR_CERT_DATE_INVALID

My web server is (include version): Apache/2.4.6

The operating system my web server runs on is (include version): Centos 7

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): FreePBX version 15

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): FreePBX manages the certificates.

How did you renew your cert?

You should probably just tell apache to reload its config: systemctl reload apache2 – but this problem will present itself again at the next renewal.

Thanks for the response 9peppe!

The cert is automatically renewed by the FreePBX software. It was worked flawlessly over the past year.

I did try “sudo systemctl reload httpd”, the service restarted successfully. But I still get the invalid date.

Any other ideas?

Brandon

well, it’s better than what I get, which is nothing at all.

are you sure it’s apache you’re talking to? you should probably tell freepbx to use the cert, I don’t know that software.

Yeah, it’s apache. Through the software (FreePBX), I can remove/install certs. I’ve tried wiping it out and generating a new one, using a different email address, but I get the same cert. I have verified the .crt and .key files are removed when I delete the cert in the software.

The software is a management console for a PBX system. It is restricted to specific IP’s, that’s probably why you don’t see anything.

To be clear, I have verified the time/date of my computer trying to access the https site. The same indications have been seen on multiple computers, from multiple networks.

Thanks. Unfortunately, that did not fix the issue. The date/time on my computer is accurate. I have tried multiple browsers/computers from two different networks. No issue for over a year, then now I have an issue. The error message says the cert expired March 7th. See attached image. If you have any other ideas I can try… I am all ears.

I really appreciate you taking the time to help me with this.

image003.jpg

Brandon

Anyone have an idea why my cert says expired? Any help would be great!

Brandon

show us the ssl-related configuration options of your freepbx, and its related logs.

1 Like

I am having pretty much the same problem. I’m running FPBX 14 and in certificate manager,it shows that my certificate has been renewed and is valid until May 2020, however when i access the URL, the certificate says invalid and shows the details for the old certificate.
I’ve deleted the certificate completely and generated a new one and but the problem still exist.

1 Like

did you import the new certificate into freepbx? (you can automate this)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.