FreeNAS cert renewal issue

Hello all,
I have a very similar issue and it is not the first time it happens to me. Last time it resolved without understanding how....
Access to my home server (FreeNAS accessed via NoIP redirect):
Browser (Chrome) says Privacy Error: NET::ERR_CERT_DATE_INVALID
Details in Chrome shows:

Issuer: R3
Expires on: Dec 3, 2021
Current date: Dec 8, 2021

So I logged on to my server and ran letsencrypt which says:

Found the following certs:
Certificate Name:
Expiry Date: 2022-03-07 20:36:05+00:00 (VALID: 89 days)
Certificate Path: /usr/local/etc/letsencrypt/live/
Private Key Path: /usr/local/etc/letsencrypt/live/

I've searched all my server for a possible other certificate (find / -name *.pem) and found nothing.
I've cleared the cache of this browser and tried from other machines including from my phone disconnected from the wifi,.... still the same error...

Any idea ?
Thanks in advance,

@carrabta Yeah, you should submit new help requests for different problems. If your problem was the same you would have been able to resolve it by reading this thread.

Did you restart Apache after updating the certificate? Servers generally need to be reloaded/restarted to start using a new certificate.

If you want help reconfiguring your Certbot install to auto reload Apache please start a new Help topic and answer the questions about the commands you used, your versions, server and so on.


Excellent! That did it. A simple:

service apache24 restart

resolved it !
Thanks a lot and sorry for same thread used - I though it was better when the problem were similar.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.