"@" for safety email - while installation


#1

Hello everybody

I wanted to activate a ssl certficate for my domain with the webroot command. Everything worked and I had to type in an email address for safety. But I couldn’t type in a “@” for my email adress and couldn’t copy with right click in this window

Thanks for helping!


#2

Hi @asdf1414, what kind of keyboard layout do you have and what operating system are you running on your own computer?

When you connect to your server via SSH, are you able to type the @ symbol at the command line outside of Certbot? For example, could you type something like this?

echo hello@there

If you can already type @ outside of this dialog, you can choose to add --email user@example.com as part of the command line that you run, which will answer this question ahead of time and stop you from being prompted for it interactively.


#3

I am using a Swiss/German Keyboard layout on Windows 10.
I can’t type in an @ outside of certbot but I can copy/paste it into the command line.
So I can run the command I ran and add > --email user@example.com behind the command?

certbot certonly --webroot -w /var/www/example/ -d www.example.com -d example.com --email user@example.com


#4

Yes, that’s correct.

You can also add the -t switch for “text” so you won’t get that (n)curses “GUI”.

See for more options: https://certbot.eff.org/docs/using.html#certbot-command-line-options


#5

I typed in the Command I posted and I got an error:

XIi0lfaMrc0Io9dm-TA: "

404 Not Found

Not Found

<p", teamquantos.net (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://teamquantos.net/.well-known/acme-challenge/p7YMMVsFNCN6IytSfS_KXeUwHxQXk3DKvb3IfV5V5wQ: " 404 Not Found

Not Found

<p"

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: www.teamquantos.net
Type: unauthorized
Detail: Invalid response from
http://www.teamquantos.net/.well-known/acme-challenge/xLSnOotghpLfazM-OJHNvRjeXIi0lfaMrc0Io9dm-TA:
"

404 Not Found

Not Found

<p"

Domain: teamquantos.net
Type: unauthorized
Detail: Invalid response from
http://teamquantos.net/.well-known/acme-challenge/p7YMMVsFNCN6IytSfS_KXeUwHxQXk3DKvb3IfV5V5wQ:
"

404 Not Found

Not Found

<p"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

I already had such an error and there was the problem I haven’t had a webserver configured for the domains I wanted to have a SSL certificate. Is this still the same error or how do I fix that?


#6

In terms of the @ sign, interesting, perhaps your terminal or SSH software is confused about your keyboard layout!


#7

The new error that you saw is not related to the previous error. As you suggested, it could to do with not have a web server set up to serve those domains in HTTP. The webroot command is based on using an existing web server which serves (in HTTP) the domains that you want a certificate for. If you don’t have that, you can’t use webroot until you do. (There are also other possible ways of authenticating your control over the domains, however.)


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.