[FIXED] Comportamento MUITO estranho

Posso ler respostas em inglês: sim

Meu nome de domínio é: botboutique.com.br

Meu servidor web é (com versão): Apache2

O sistema operacional no meu servidor web é (com versão): Ubuntu 18.04

O serviço de hospedagem do meu site (se aplicável) é: Locaweb

Posso acessar um shell root na minha máquina (sim ou não, ou não sei): sim

Uso um painel de controle para administrar meu site (não, ou indique o nome e a versão do painel de controle): não


Olás!

Usei o certbot (# certbot --apache) para instalar o SSL no meu site. Apesar de constar como instalado, meu servidor não direciona para o certificado.
https://www.whynopadlock.com/results/419ba363-1aa3-4e12-8e0a-5f3193b65d5a

Então, eu consigo acessar http://www.botboutique.com.br e suas variações, mas qdo eu tento acessar via HTTPS o servidor me retorna um código 404.

Eu usei esse link tb (https://crt.sh/?q=botboutique.com.br) mas eu não entendi o output.

Agradeço qualquer suporte :slight_smile:

LuizC

1 Like

The site is using TLS with a valid LE certificate:
https://www.ssllabs.com/ssltest/analyze.html?d=botboutique.com.br

The “padlock” problem is probably due to “mixed content”; where your site has objects embedded by HTTP.
[that is NOT a good idea; within a secure site all content need to be secure]

1 Like

Thanks for you answer, @rg305

But how can we explain the fact that despite the correct instalation, trying to reach https://botboutique.com.br returns a 404 code?

1 Like

There is a redirect that messes everything up:

curl -Iki https://botboutique.com.br/
HTTP/1.1 302 Found
Date: Wed, 03 Jun 2020 19:25:53 GMT
Server: Apache/2.4.29 (Ubuntu)
Location: http://vps18569.publiccloud.com.br/404.html
Content-Type: text/html; charset=iso-8859-1

2 Likes

Yes, @rg305 that’s the url of the server that is hosting www.botboutique.com.br

How to fix it?

1 Like

The problem seems to be within the Apache configuration (unless you have any add-on like WordPress).
Let’s start with:
apachectl -S

1 Like

@rg305

1 Like

@rg305, when I type

apachectl -S > log.txt

I get this:

AH00112: Warning: Document root [/var/www/botboutique/html] does not exist
[Wed Jun 03 16:56:11.679413 2020] [core:notice] [pid 91776] AH00113: /etc/apache2/apache2.conf:236 cannot use a full URL in a 401 ErrorDocument directive — ignoring!

And the correct adress in my server should be “/var/www/www.botboutique.com.br/html”.

Can we know from where the wrong adress is called and fix it?

1 Like

After looking with more attention to apachectl -S output, I fix the issue going to

/etc/apache2/sites-enable/apache2-le-ssl

and write the correct folder where HTTPS version resides. Work fine now.

:slight_smile:

2 Likes