First time using letsencrypt didnt seem to produce a good cert

hello - (centos7-apache)

so far so good switching from comodo to letsEncrypt. my first attempt did not seem to produce very good results:
https://www.ssllabs.com/ssltest/analyze.html?d=canyonverde.church&hideResults=on

perhaps this is because the first time i ran, i used the –test-cert option, since the –help option said “Obtain a test certificate from a staging server” which sounded as if this is a good option for a newbie just to play around with.

but then i ran again without the switch and everything seemed to go fine.

do we need to wait before the certs are indeed fully accepted?

Hi @edwardsmarkf,

That site isn’t listening in HTTPS at all.

Your certificate has been successfully issued

https://crt.sh/?Identity=%canyonverde.church&iCAID=16418

but the web server still needs to be configured to use it and to answer HTTPS requests.

thanks – i redid everything using a NEW vpn:

  1. google-console, create centos7 vpn
  2. yum install everything
  3. created a vps: https://www.godaddy.com/help/configure-apache-virtual-hosts-centos-7-17338
  4. checked using http://canyonverde.church:80/index.html
  5. installed certbot-auto
  6. ./certbot-auto;
  7. make sure https://canyonverde.church:443/index.html loads successfully

this link looks very good: (using canyonverde.church) https://www.geocerts.com/ssl_checker

but i get the same results here as before:
https://www.ssllabs.com/ssltest/analyze.html?d=canyonverde.church&hideResults=on

any suggestions?

certbot-auto run results below:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter ‘c’ to
cancel): mark@XXXXXX.com


Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v01.api.letsencrypt.org/directory

(A)gree/©ancel: A


Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let’s Encrypt project and the non-profit
organization that develops Certbot? We’d like to send you email about EFF and
our work to encrypt the web, protect its users and defend digital rights.

(Y)es/(N)o: Y

Which names would you like to activate HTTPS for?

1: canyonverde.church
2: www.canyonverde.church

Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for canyonverde.church
Waiting for verification…
Cleaning up challenges
Created an SSL vhost at /etc/httpd/sites-available/canyonverde.church-le-ssl.conf
Deploying Certificate for canyonverde.church to VirtualHost /etc/httpd/sites-available/canyonverde.church-le-ssl.conf
Enabling site /etc/httpd/sites-available/canyonverde.church-le-ssl.conf by adding Include to root configuration

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.

1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Redirecting vhost in /etc/httpd/sites-enabled/canyonverde.church.conf to ssl vhost in /etc/httpd/sites-available/canyonverde.church-le-ssl.conf


Congratulations! You have successfully enabled https://canyonverde.church

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=canyonverde.church

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/canyonverde.church/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/canyonverde.church/privkey.pem
    Your cert will expire on 2018-04-25. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot-auto
    again with the “certonly” option. To non-interactively renew all
    of your certificates, run “certbot-auto renew”

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

I don’t know what you’ve done differently now, but it now works properly and says “Hooray! Your virtual host is working!”.

I don’t know what you’ve done differently now

i started over from scratch.

however, this link still does not like the cert:

Please look again—your test was apparently out-of-date.

thank you very much - you might consider adding to the https://ssllabs.com/ssltest/ link at the end of the certbot procedure something like “you may experience a time delay before the ssllabs.com results are accurate.

Normally they are accurate immediately, so I’m not sure what was going on in your case or what changed between one time that the test ran and another.

What happens is that ssllabs caches test results. The first time you run their test on your domain, it will give you accurate results at that time. If you try again in 10 minutes, it will serve up cached results (though there’s a link on there to re-run the test). I don’t remember how long they cache, though it’s definitely less than 24 hours.

2 Likes

yeah i figured there was some sort of caching going on there. my FINAL issue was nothing to do with lets-encrypt (which is totally awesome) but rather with the SSLv3 issue.

even though i did the “patch” as far as apache was concerned, it took several hours before ssllabs reloaded my page.

before i realized there was caching going on, i kept thinking that i put the SSLv3 in the wrong place. far be it from me to point out that godaddy’s instructions need some updating.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.