Filemaker Server as odbc source

Dear Sirs,

getting the ssl certificate worked fine including renew.

What I want is to use the filemaker Server (v19.3) as an odbc source.Things worked fine during summer with the setting.

Here is my Problem:

When connecting to the server there is an authentication error on the windows. Same setting on macOS works just fine.

My domain

I ran this command: ODBC Connect

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): Mac OS X 10.15.7

My hosting provider, if applicable, is: myself

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): FilemakerServer AdminConsole

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot 1.21.0 // zsh: command not found: certbot-auto

Sorry, but maybe I'm not understanding due to lack of information, but how is this related to Let's Encrypt exactly?


The form lacks the obvious...
And tell us what problem you are having or any other relevant details.

1 Like

What does the "Filemaker Server (v19.3)" documentation say about encryption for ODBC?

1 Like

nothing .....

Then how can you be sure that it can even use an LE cert (or any cert) with ODBC?

1 Like

the cert is not officially supported but worked fine for about 6 month

it works fine on the client on Mac and win and in the web direct environment

OK, let's play 20 questions!

How did you get it to use an LE cert... 6 months ago?

[you are now the only available documentation for that - LOL]

1 Like


sudo certbot certonly --webroot -d --agree-tos -m --preferred-challenges "http"

That get's you a cert - GOOD.
How was it used with ODBC?

1 Like

that is a black box for the dummie... but the connector shows

Versuch, eine Verbindung mit Datenbank P21Datenconta auf Host (trying to Connect to..) herzustellen...

Datenbankversion: FileMaker 19.3.2

VerschlĂĽsselung: ECDHE-RSA-AES256-GCM-SHA384 TLSv1.2 (Encryption)

SSL-Zertifikat: /

Test erfolgreich abgeschlossen. (test successful completed)

1 Like

On to question number five.
[this is 25% of my questions and I'm not really seeing any progress here]

Isn't that "test successful completed" mean that everything is good - what is the problem?
[trying to ask two questions at once - LOL]

1 Like

I do not want to bother you,,, Just trying for 24h prior to my asking for help!

When connecting via ODBC64 in the qilkView app it shows an error using the same User/pwd

Verbindung erfolgreich getestet (Connection tested successfully)
Connector connect error: SQL##f - SqlState: 28000, ErrorCode: 212, ErrorMsg: [FileMaker][FileMaker] (212): Invalid account/password

1 Like

I am not bothered - I like the game (so far).

That is not much of a clue - hard for me to move to the next question...
Give me one minute.

1 Like

Q6: Is there anyway to manage user accounts - to change your password (and thus confirm it)?

[ and thank you for the translations :heart: ]


I will create a new user.. 2m min please

1 Like

running ... you are the magical mechanic .. Thanks so much!
Seems to be a filemaker or QlikView issue (caching of credentials?)

. Thanks so much!


6 out of 20



Glad to hear that!
[I still had 14 questions left to use - LOL]

Cheers from Miami :beers:
#FreeCUBA :cuba:

1 Like