Failing to serve .well-known/ in Nginx

My domain is: gitea.lilywhite.dev

I ran this command: certbot -vvv --test-cert --nginx

It produced this output: Ubuntu Pastebin

My web server is (include version): nginx/1.18.0

The operating system my web server runs on is (include version): ubuntu 20.04

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.22.0

P.S. I have created a certificate for git.lilywhite.dev before, but I then nuked my VPS and forgot to backup the .pem files.

1 Like

Welcome to the community @LilyWhite

Thanks for all the details and the log. Can you explain why your Beaver server is responding? From the nginx conf I see in your log, I would expect a 404 response to this request from nginx. But, instead I see a 403 response from Beaver.

curl -I  gitea.lilywhite.dev/.well-known/acme-challenge/Test-Forum-123
HTTP/1.1 403 Forbidden
Server: Beaver
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 597
Connection: close
2 Likes

I'm not being definitive, but I suppose it's the registration process
needed for hosts located in Mainland China that got in the way.

I tried manually creating the .well-known path and the cloud service
provider's prompt of registration showed up.

I'm now filling the paperwork and I'll see whether it still breaks after
it's done

1 Like

OK, thanks. It is still puzzling why you issued some certs earlier then but post back if that paperwork does not help.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.