Failed to install Let's Encrypt for domainname.com. External task is already running

Hi,
When i tried to create a ssl certificate for my domain it shows this message " Failed to install Let's Encrypt for domainname.com External task is already running"...
Before that i tried to renew my expired certificate but it does not show any changes so i delete a old one tried to install a new certificate...Then this messages are shown...Pls help me to solve this...

1 Like

Hi @sherin and welcome to the Community.

First, I have absolutely no idea what you're talking about. You talk about "tried to create a ssl certificate", but you're not telling us how. I.e., what ACME client did you use, what exact command did you use et cetera. Unfortunately, we in this Community, aren't omniscient, altough sometimes it might look like that :wink:

Fortunately, when you started this thread in the "Help" section, you should have been presented with a questionnaire. It might not have showed up, or you might have deleted it manually. In both cases, I'm going to put the questionnaire back (again) for you to fill out to the best of your knowledge. Because without any details, we'd need a crystal ball...


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

2 Likes

OK, so I assume (because you didn't literally answer all the questions) you don't have root access to the server, but are on shared hosting (again, assumptions...). That would mean there isn't really anything you can do at this moment besides what you've already done.

I would advice you to contact Siteground ASAP, because I think it's their issue, not yours.

2 Likes

Ok... Thanks for your reply...

2 Likes

Good luck! Hopefully Siteground can fix this easily and quickly for you :slight_smile:

2 Likes