Failed to connect to host for acme-challenge

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

Following the indications found here:

(base) marco@pc01:~/webMatters$ git clone
Cloning into ''...
remote: Enumerating objects: 9876, done.
remote: Total 9876 (delta 0), reused 0 (delta 0), pack-reused 9876
Receiving objects: 100% (9876/9876), 3.86 MiB | 5.36 MiB/s, done.
Resolving deltas: 100% (5801/5801), done.
(base) marco@pc01:~/webMatters$ cd
(base) marco@pc01:~/webMatters/$ sudo mkdir data

root@pc01:/home/marco/webMatters/ --issue -d -d 
--webroot /var/www/ --force --debug 2

It produced this output: error:Fetching
/2hDrD9c1PpCBlMdccXRu-c5LEaJ2bSW52kEkU9V6Dvw: Connection refused

Please refer to for error code: 7


Failed to connect() to host or proxy. 

Here the complete log: FailedToConnectToHost.txt (51.5 KB)

My web server is (include version): nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.4 Desktop

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Looking forward to your kind help.

1 Like

This is your problem–your server is refusing connections from the outside world. You need to fix that before Let’s Encrypt will be able to issue a cert.

1 Like

After dis-installing and completely removing nginx and, re-installing them again from scratch, and retrying to issue certificates, and getting the same “Connection refused” without any apparent reasons, and this for two times, I decided to try with Certbot.
I followed the well done indications found here: and got the certificates, which, according to has an overall rating of A.

But with I get this error:
|C| Error - no version with Http-Status 200

|H| fatal error: No https - result with http-status 200, no encryption

For this new error type I opened a new Help Request: Https:// : fatal error: No https - result with http-status 200, no encryption

1 Like

There appears to be a routing issue (or firewall issue):

curl -Iki
curl: (7) Failed to connect to port 80: No route to host

Pinging [] with 32 bytes of data:
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
PING ( 56(84) bytes of data.
From ( icmp_seq=1 Destination Host Unreachable
From ( icmp_seq=2 Destination Host Unreachable
From ( icmp_seq=3 Destination Host Unreachable
From ( icmp_seq=4 Destination Host Unreachable
--- ping statistics ---
7 packets transmitted, 0 received, +4 errors, 100% packet loss, time 6075ms
1 Like

There are a lot of checks created today -

www and non-www worked, last check is ~~30 minutes old.

So the server is now offline.

1 Like

@rg305 I beg your pardon.

I’ve been modifying nginx configuration on the fly.

Now according to I’ve got Content problems-mixed content,missing files.

and according to the overall rating is A+

1 Like

Well… the “problem” persists (at least from where I’m connected to the Internet):

or maybe an IPS or Geo-Location blocking system is in play.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.