Failed to connect to 139.59.18.213 :443 for TLS-SNI-01 challenge


#1

Now I think I have to wait 7 days to retry.I just want my website to stop redirecting to https .my config file:

    server {
       # listen 80 ;
       # listen [::]:80 default_server;

        # SSL configuration
        #
         listen 443 ssl default_server;
         listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
         # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;

        root /var/www/laravel/public;

        # Add index.php to the list if you are using PHP
        index index.php  index.html index.htm index.nginx-debian.html;

        server_name aksout.com ;

        ssl on;
        ssl_certificate /etc/letsencrypt/live/aksout.com/fullchain.pem;
       ssl_certificate_key /etc/letsencrypt/live/aksout.com/privkey.pem;
          location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ /index.php?$query_string;
        }
            location /phpmyadmin {

             alias /var/www/laravel/public/;
              index index.php index.html index.htm;
             }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
           location ~ \.php$ {
                                    include snippets/fastcgi-php.conf;
              fastcgi_split_path_info ^(.+\.php)(/.+)$;

        #       # With php7.0-cgi alone:
        #       fastcgi_pass 127.0.0.1:9000;
        #       # With php7.0-fpm:
                fastcgi_pass unix:/run/php/php7.0-fpm.sock;



                include fastcgi_params;



                 fastcgi_buffers 8 512k;
        fastcgi_buffer_size 256k;
        fastcgi_send_timeout 5m;
        fastcgi_read_timeout 5m;
            fastcgi_connect_timeout 5m;
        }

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        location ~ /\.ht {
                deny all;
        }
              location ~ /.well-known {

                allow all;}


}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.

         server {
       listen 80;
#       listen [::]:80;
#
     server_name aksout.com;
#
#       root /var/www/example.com;
#       index index.html;
#
#       location / {
#               try_files $uri $uri/ =404;
#       }

    return 301 https://aksout.com$request_uri;
}

#2

Well, that piece of code is responsible for the redirect, so commenting that one out would remove the redirect. (And reloading nginx after the change obviously…)

You would also need to uncomment the root and index directives for your site to work.

Edit:
Looks like you already managed to figure that out on your own, as your site is already accessible through HTTP at the moment…


#3

yes but how would i resolve this error?


#4

That depends on how you tried to renew your certificate. The Help category has the followin quesionnair:

Please fill out the fields below so we can help you better.

My domain is: aksout.com

I ran this command (preferably the initial command for the first cert, as wel as the command for renewal):

It produced this output:

My operating system is (include version):

My web server is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.