Failed authorization when renewin cert


#1

Hi everybody,

So this morning when I tried to go on my website, I got a Privacy error, apparently my cert is expired, so I tried to renew it with the commande “./opt/letsencrypt/letsencrypt-auto --expand”, I selected my domain, and i got this error message :

“Failed authorization procedure. www.shop.beeshary.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: NXDOMAIN looking up A for www.new.beeshary.com”.

Renewing my cert worked in the past, so I don’t know why it won’t work this time.

My domain is: www.beeshary.com

I ran this command: ./opt/letsencrypt-auto --expand

My operating system is (include version): openSUSE 13.2 (Harlequin) (x86_64) 64-bit

My web server is (include version): Apache 2.4

I can login to a root shell on my machine


#2

It fails for the reason it says - " DNS problem: NXDOMAIN looking up A for www.new.beeshary.com".

If I try and go to your domain -

curl -I www.shop.beeshary.com
curl: (6) Could not resolve host: www.shop.beeshary.com

or

host www.shop.beeshary.com
Host www.shop.beeshary.com not found: 3(NXDOMAIN)

You need to check your DNS records, and ensure that the A or CNAME record exists for www.shop.beeshary.com


#3

I checked on OVH, and I got a CNAME for shop.beeshary.com, new.beeshary.com and www.beeshary.com (but not beeshary.com), however I got a A for beeshary.com.

www.shop.beeshary.com actually doesn’t exist, it’s https://shop.beeshary.com.

I’ve got no idea what to do right now. :confused:


#4

The cert for https://shop.beeshary.com. is OK until the 12th Dec. Just don’t include the www.shop.beeshay.com when you try and renew the cert :wink:


#5

Oh, ok, I just got it… Since my url are http://mydomain.com and not www.mydomain, I had DNS errors, thanks a lot for your help, you juste savec my day ! Can I make it so my cert expand automaticly ? And how can I delete www.shop.beeshary.com www.new.beeshary.com from the letsencrypt-auto list ?


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.