Failed authorization procedure. during connect (likely firewall problem)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx -d

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: The server could
not connect to the client to verify the domain :: Fetching
yGB8JeNwkJ113KjshMd2V14Jhb9LzxpvA9k: Timeout during connect (likely firewall problem)


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):

The operating system my web server runs on is (include version): nginx version: nginx/1.14.0 (Ubuntu)

My hosting provider, if applicable, is: self-hosted

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

I am using google domain and home server. I could http my server. Also, I have allowed Nginx Full in ufw.
$ sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), deny (routed)
New profiles: skip

To Action From

80,443/tcp (Nginx Full) ALLOW IN Anywhere
80/tcp ALLOW IN Anywhere
80,443/tcp (Nginx Full (v6)) ALLOW IN Anywhere (v6)
80/tcp (v6) ALLOW IN Anywhere (v6)
I have searched for similar issues but most of them are hosted on cloud.

It looks like there is no webserver listening on port 80 on your server, check with sudo ss -tlpn -HO

% nmap
Starting Nmap 7.80 ( ) at 2020-04-03 10:26 CEST
Nmap scan report for (
Host is up (0.19s latency).
rDNS record for
Not shown: 999 filtered ports
443/tcp closed https

Nmap done: 1 IP address (1 host up) scanned in 13.65 seconds

It can also be your ISP blocking port 80.

Thanks for your reply!

I also tried this on another computer same lan. It seems that port 80 shows up (might be I am under the same lan or maybe same ISP?)

Anyways, what should I do if I still want to proceed with certbot? How should I change/forward port 80 for cerbot?


port 80 on your public ip should go to port 80 on the machine running your webserver/certbot.


there is no answer. See

Domainname Http-Status redirect Sec. G -14 10.033 T
Timeout - The operation has timed out -2 1.544 V
ConnectFailure - Unable to connect to the remote server -14 10.053 T
Timeout - The operation has timed out

Your port 443 is blocked via a firewall. Your port 80 doesn’t answer. A working port 80 is required to use http validation.

Thanks guys. I was able to use to get certificates over port 443.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.