Failed authorization. Invalid response

My domain is:

I’ve tried both of these commands:
sudo certbot certonly --webroot -w /var/www/html -d
sudo certbot certonly --authenticator webroot --installer apache --webroot-path /var/www/html -d

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from "\ufeff…

My web server is (include version):

The operating system my web server runs on is (include version):
Ubuntu 16.04.3 LTS (GNU/Linux 4.11.0-1016-azure x86_64)

I can login to a root shell on my machine (yes or no, or I don’t know):
Not sure. Buy I’ve got access to sudo command.

I’m using a control panel to manage my site: No.

I have read many posts with the same problem and I’ve already checked that the /.well-known directory is writeable and accessable.
The domain does not contain any AAAA-records.

This domain is pointing to a subsite of a Wordpress multisite network. Could that be part of the problem?

Thank you for any help you can provide in this.


I think the reason for that error is you are using wp.
And they redirect you from the acme challenge to an error 404 page.

Also, if you are using webroot, you don’t need to point the webroot to your website folder. (Just need a public accessable folder other than your website to avoid problems.)

Hi @linda.mansson,

Where on your system did you create the test.txt file that we can see from your link?

Thank you both! I used the dedicated uploads folder for the webroot, and now it worked!

Unfortunately the domain is still doesn’t seem to use the certificate. The website is till “unsafe” according to the webbrowsers. But I’m guessing that is a Wordpress multisite problem since the main site for the network has a working certificate also generated with certbot.

I've manged to get everything to work properly with help from this thread:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.