Errors while uploading the lets encrypt SSL certificates

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cloudeez.club

I ran this command:
I generated ssl certificates to use it on Elastic cloud enterprise
It produced this output:
Certificate chain was invalid [Invalid Entry: expected unencrypted rsa private key]

My web server is (include version):
Nginx-latest on Centos 7

The operating system my web server runs on is (include version): Centos 7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
[root@nginx ece.cloudeez.club]# certbot --version
certbot 0.31.0

As per Elastic cloud enterprise, I am trying to upload the certificates, for your reference i am providing their documentation https://www.elastic.co/guide/en/cloud-enterprise/current/ece-manage-certificates.html

  1. Log into the Cloud UI.
  2. From the Platform menu, select Settings .
  3. Under TLS settings for the Cloud UI, click Upload new certificate and select a concatenated file containing your RSA private key, server certificate, and CA certificate. Upload the selected file.To see the details of the certificate you added, click Show certificate chain .

I uploaded the certificates and getting the below error,

Certificate chain was invalid [Invalid Entry: expected unencrypted rsa private key]

Could you please help

#2

Hi @eagleeye,

How did you make the file that you tried to upload? Certbot itself doesn’t generate a “concatenated file containing your RSA private key, server certificate, and CA certificate”; none of its output files contain all of this information in a single file. (In Certbot terms, this file would be the combination of privkey.pem with fullchain.pem.)

#3

Hi,

I have solved the problem

Elastic cloud enterprise had an option to upload certificates, that option was throwing errors, now I used nginx configuration for ssl and it worked fine.

Thanks a lot for responding.