Error: Your Domain is not pointing to the correct IP address of your server

My domain is: https://blog.sellerssuite.com

Issue:
My ssl auto-renew didn’t work. So I attempted to manually renew the SSL. However, I kept getting this error. So I figured there was something wrong with the setup.I did a fresh instance and I’m still getting this error.

I’m using Route53 and I’m sure the correct IP address is showing and the DNS has propagated - you can see here https://dnschecker.org/#A/blog.sellerssuite.com

It produced this output:
Your domain name is not pointing to the correct IP address of your server, check your DNS has propagated and run ghost setup ssl again

My web server is (include version):
Ubuntu 18.04

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
AWS

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No

Has anyone experienced this issue? Any idea how to solve it?

1 Like

Solved. It was a security group setting. I didn’t allow access to port 80. I guess it needed that to renew the cert.

4 Likes

Glad you figured it out! Yes, it does need port 80. For more information on this topic, you can see


1 Like