Error with domain with www


#1

I run the command to crea

My domain is: example.com

I ran this command: ./certbot-auto --renew-by-default --email mail@example.com --text --agree-tos -d example.com -d www.example.com
to create my new certificate, but the output is
Domain: www.example.com
Type: unauthorized
Detail: Incorrect validation certificate for TLS-SNI-01 challenge.
Requested

I’m using a virtual machinte CentOS 7 to create the certificate that i will upload to a shared hosting plan

My web server is Apache/2.4.6 (CentOS)

So, the output error is with the domain with www.

What am i missing.

Thanks


#2

This virtual machine, does it have the IP address associated with your domain name(s)? Or is it completely different?


#3

no, is different, i have it in my computer, the ip is private


#4

You can only obtain certificates for domains that Let’s Encrypt can verify ( so it needs to be publicly accessible ) .

You may be able to use the DNS-01 challenge (which requires you to place a token in the DNS records, rather than proof by accessing your domain website )


#5

Addition to @serverco: the domain name in question also needs to be public for obvious reasons.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.