Error while running apachectl -v

My domain is:

I ran this command:
certbot --authenticator standalone --installer apache -d --pre-hook “systemctl stop httpd” --post-hook “systemctl start httpd”

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Error while running apachectl -v.

apachectl: The “-v” option is not supported.

My web server is (include version):
apache 2.4.39

The operating system my web server runs on is (include version):
Fedora 29

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

This all worked before my last dnf check-update.

Seems to be a known issue…

I suppose, as a workaround you could use certonly and install the certificate manually.

I just tried:

sudo certbot --apache certonly

and it failed with the same error message.

Sorry, my suggestion to use certonly was directed at @ianm who was already using --authenticator standalone etc. More specifically the workaround is to avoid using the apache plugin entirely, so you could use certbot certonly --webroot for example and that should work.

Meanwhile, a new version of certbot has since been released which I believe should have a fix for this issue. Although I don’t know if the Fedora package has been updated yet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.