Error while Installing certbot - apace2ctl

Hello i hope anyone can help me its the first time for me trying to get an Let*s encrypt Certificate. I used google on my error results but wasnt able to understand if the solutions will work in my case and due its security think i would prefer tipps from some ppl who know.

I have serveral Domains who are all pointing on one server , My Apace2 configs direct them to seperate Folders which contain the datas for the seperate Domains
Example: www.oflol.eu.conf

<VirtualHost *:80>
ServerName www.oflol.eu
ServerAdmin webmaster@localhost
DocumentRoot /var/www/Oflol/
<Directory /var/www/Oflol/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Require all granted

ErrorLog /var/log/apache2/error.log
LogLevel warn
CustomLog /var/log/apache2/access.log combined
ServerSignature On

My domain is: tkablage.eu / tkablage.de / oflol.eu .....

I tryed to install chertbot following this guide Certbot - Ubuntubionic Apache everthing works smooth till it will start the apache2ctl.

I ran this command on Step 7 : certbot --apache

It produced this output:
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 1
Keeping the existing certificate (I tryed to run this serveral times hope i just messed up before thats why there are serveral certificates)
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/laila-tim.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/www.laila-tim.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/oflol.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/www.oflol.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/tkablage.de-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/tkablage.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/www.tkablage.eu-le-ssl.conf
Deploying Certificate to VirtualHost /etc/apache2/conf-enabled/www.tkablage.de-le-ssl.conf
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs

Unable to restart apache using ['apache2ctl', 'graceful']
Rolling back to previous server configuration...
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs

Unable to restart apache using ['apache2ctl', 'graceful']
Encountered exception during recovery: certbot.errors.MisconfigurationError: Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs

The operating system my web server runs on is (include version): Ubuntu 18.04.5 LTS

My hosting provider, if applicable, is: netcup

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

1 Like

The problem appears to be that you have OpenVPN-AS running on port 443.

Certbot tries to setup HTTPS Apache virtualhosts on port 443 as well, and this leads to a conflict: Apache can't start because OpenVPN-AS is already using that port.

Could you consider relocating OpenVPN-AS from port 443 to another port?

3 Likes

omg crap thank you verry this was it and fixed it.

2 Likes