Error trying to renew in Debian 8: 'EntryPoint' object has no attribute 'resolve'


#1

Hi,

One of my servers has started complaining about a renewal (there are others working like a charm). All of them Debian 8 with Apache. I’ve seen there is a bug report on Debian about it but I can’t get a workaround and the cert expires in some days…

Please fill out the fields below so we can help you better.

My domain is: vader.sargue.net

I ran this command: sudo certbot renew

It produced this output:

someone@somewhere:~$ sudo certbot renew

-------------------------------------------------------------------------------
Processing /etc/letsencrypt/renewal/vader.sargue.net.conf
-------------------------------------------------------------------------------
2016-09-15 08:57:56,546:WARNING:certbot.renewal:Attempting to renew cert from /etc/letsencrypt/renewal/vader.sargue.net.conf produced an unexpected error: 'EntryPoint' object has no attribute 'resolve'. Skipping.

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/vader.sargue.net/fullchain.pem (failure)
1 renew failure(s), 0 parse failure(s)

My operating system is (include version): Debian 8 32 bits

My web server is (include version): 2.4.10-10+deb8u5

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

@bmw @hlieberman Could one of you take a look at this?


#3

Both Harlan and I have responded on GitHub.


#4

Workaround worked. Using wrapper instead of debian package. Instructions if you select Debian 7 on the certbot page. More details on the github issue.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.