Error on Installation - acme==0.2.0.dev0


#1

Hi,

I tried to install the Letsencrypt in a AWS EC2 machine running Ubuntu 14.04.1 MEAN Stack by Bitnami but it is not working at all. When I runned the command python setup.py install I’ve got the following error:

Searching for acme==0.2.0.dev0 Reading https://pypi.python.org/simple/acme/ No local packages or download links found for acme==0.2.0.dev0 error: Could not find suitable distribution for Requirement.parse('acme==0.2.0.dev0')

Does anyone know how to solve it? I think that the version 0.2.0 doesn’t exist, but I don’t know how to tell it to use the 0.1.0 instead.

Thanks in advance,
Lucas


#2

Please don’t run python setup.py or anything similar directly. use ./letsencrypt-auto as indicated by the docs. letsencrypt-auto will install all required dependencies and set up a virtualenv for you.


#3

Using ./letsencrypt-auto is not working as well.

It says that cannot find pip. However, if I run $ pip --version it is working, but is not located in the folder that Letsencrypt expects.


#4

Not sure if this is a side-effect of running setup.py manually. I would recommend deleting your letsencrypt folder and ~/.local/share/letsencrypt, then repeat the installation steps according to docs.


#5

Already tried it many times. I get always the same pip error.

Run the ./letsencrypt-auto was my first try.

I think that it is a problem with Ubuntu 14.04.1 or with the Bitnami Image. The client is working for me in a CentOS.


#6

I was able to reproduce this on a fresh Bitnami MEAN stack EC2 instance. Detailed error message when I try to activate the venv:

Running virtualenv with interpreter /opt/bitnami/python/bin/python2
PYTHONHOME is set.  You *must* activate the virtualenv before using it
New python executable in venv/bin/python2
Also creating executable in venv/bin/python
Cannot locate wrapped file
ERROR: The executable venv/bin/python2 is not functioning
ERROR: It thinks sys.prefix is u'/root/letsencrypt' (should be u'/root/letsencrypt/venv')
ERROR: virtualenv is not compatible with this system or executable

I found some similar reports indicating Bitnami doesn’t support virtualenv (this is for a different image, but might apply to MEAN as well):

You might have more luck over at the Bitnami community forum, since this seems specific to them.

Vanilla Ubuntu 14.04 works without issues.


#7

So you can’t just
wget https://bootstrap.pypa.io/ez_setup.py -O - | sudo python
easy_install pip
easy_install virtualenv
?