Error on Domain, unaccessable

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: pikespeakpopwarner.org

I ran this command:

It produced this output:

My web server is (include version):
The operating system my web server runs on is (include version): linux

My hosting provider, if applicable, is: lightsail

I created a website, then tried to move the domain to it (the IP Address). I ran into trouble because I did not realize Wix (where the domain dns is hosted) would not allow nameserver changes. My reaction was to buy a related domain and start over, but I think i created conflict by doing so. Now my site is not accessible and I believe I need to remove let’s encrypt and start over on the new domain. My ip is 44.232.57.167

How can I best solve my problem?

What is your end goal?

Your domain doesn’t have an A record, it’s not surprising it doesn’t load anything, it’s not pointing to an actual machine.

You’re having a lot of DNS problems. I’m missing how Let’s Encrypt is involved? I’m certainly not seeing Let’s Encrypt being any part of the solution to your issues.

That’s interesting. I show an A record in lightsail pointing to the correct ip.

It’s possible with the changes it is just a DNS propagation issue. It occurred after the change in let’s encrypt…I can be patient.

I deleted and re-added. My end goal is to get the new domain and my website connected and visible. I was assuming since I started let’s encrypt prematurely on a different domain name with the same IP it caused a problem with let’s encrypt. It’s possible my DNS just needs time from all the confusion.

there are no NS records either… (you need the registrar to add those)

# dig ns pikespeakpopwarner.org

; <<>> DiG 9.11.3-1ubuntu1.11-Ubuntu <<>> ns pikespeakpopwarner.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 31334
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;pikespeakpopwarner.org.                IN      NS

;; Query time: 1902 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Tue Mar 10 23:45:46 CET 2020
;; MSG SIZE  rcvd: 51

and yet…

% whois pikespeakpopwarner.org
Domain Name: PIKESPEAKPOPWARNER.ORG
[...]
Name Server: NS-1242.AWSDNS-27.ORG
Name Server: NS-62.AWSDNS-07.COM
Name Server: NS-581.AWSDNS-08.NET
Name Server: NS-1840.AWSDNS-38.CO.UK
[...]