Error message after trying to add domain

Hi all, i hope you are doing great today?

So i have an question, and hopefully one of you guys can help me out.

Here in the office we are getting more and more Linux machines (servers) and we want to secure the web connection. Therefore we need SSL certificates.

And LetsEncrypt is the best solution for us. Also because the servers will be only reached out internally.

So my situation is as followed.

  1. ESXi host
  2. Debian11 installed
  3. LAMP installed, apache is running
  4. Trying to install, configure now Certbot.

So each time when i enter the domain i receive an error message.

Hopefully someone can help me out, this error message i received on basically all of our server in Linux.
PS: tried it also without subdomain its the same error message.

Also to mention, this specific VM is added in a VLAN what is directly to the internet, once it received the certificate and it works, it will be moved to an VLAN only what is for the internal network, so i will need to re-add it each time manually.

Hello @thehazzard, welcome to the Let's Encrypt community. :slightly_smiling_face:

What did you find out when you traced down on this?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thank you for assisting us in helping YOU!



Thank you for your support,

Some background information
I am 100% new to Linux. Here at the office our main products are windows clients and servers. On the server side I have managed to install the certificate authority CA on Windows server 2019, and give out to our machines the certificates.

But some machines now we need Linu, like for our CMDB. And it was my first try. Read some documentation for what is needed to have. Apache webserver was one of them. So i tried to install LAMP just in case I mis something.
Only what a issue was the network firewall modify. Need to check that one as well.

I have installed the following:

  • Debian11 with GUI (not a command line person)
  • updated all the repos what was needed.
  • installed LAMP Apache webserver (Apache site is reachable it shows the Apache Frontpage)
  • followed all the steps for certbot until the issue pops up.
  • the test bench is at the moment on our external network vlan. Once it works it will be moved to the internal vlan where our other servers are.
    Internally the DC01 & DC02(backup server) are our main dns servers.


For any commands I don't know what to enter. So please be patient. I will reply on time, since I receive the notifications.

1 Like

When using HTTP-01 authentication, the CA [LE] will need to connect to the server to validate "ownership/control".
So, you will need a working HTTP site before you secure it.
Can the internet reach your Apache web server [via] ?
If not, that is "Step #1".


Testing and debugging are best done using the Staging Environment as the Rate Limits are much higher. Rate Limits are per week (rolling).

You can check you DNS with

And to assist with debugging there is a great place to start is Let's Debug.

Please look to Apache forums as well

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.