Error in creating in Certificate


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:batch.tabsandsyrups.com

I ran this command:
sudo certbot certonly --manual

I have crated a file in static folder in such way that

http://batch.tabsandsyrups.com/.well-known/acme-challenge/a-string
will download a file containing the string mentioned in command prompt

When tried from browser a file will be downloaded with the name a-string containing the token.

It produced this output:
Domain: batch.tabsandsyrups.com
Type: unauthorized
Detail: Invalid response from
http://batch.tabsandsyrups.com/.well-known/acme-challenge/Ii13sCW5iuZNIhnMhMGVHXh-s2W7WPQNonO6CAXD6lg:
"<!doctype html>

   <head>
       <meta http-equiv="Content-Type" content="text/html;

charset=utf-8">
<meta htt"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version): express server running in Debian 9

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: not applicable

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no


#2

Are you sure your domain is correctly pointed at your server? If I request http://batch.tabsandsyrups.com/.well-known/acme-challenge/a-string I seem to get a GoDaddy URL shortener. If I request http://batch.tabsandsyrups.com/ I get a 301 redirect to a Google Cloud IP address (HTTP on port 8443), which is running Express so I guess that’s your server.

I’m guessing you probably want to point the domain directly at the Google Cloud server using an A record, rather than a redirect. You’ll also need a webserver on port 80 to complete the challenge.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.