Error during renewal : KeyError: 'handle_modules'


#1

My domain is: heimdall.inpixal-services.com

I ran this command: ./letsencrypt-auto renew

It produced this output:

An unexpected error occurred:
KeyError: ‘handle_modules’
Please see the logfile ‘/tmp/tmpumk33f’ for more details.

Contents of the log ‘/tmp/tmpumk33f’ :

2018-09-06 12:06:21,640:DEBUG:certbot.main:certbot version: 0.27.0
2018-09-06 12:06:21,640:DEBUG:certbot.main:Arguments: [’–version’]
2018-09-06 12:06:21,640:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2018-09-06 12:06:21,643:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/bin/letsencrypt”, line 11, in
sys.exit(main())
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/main.py”, line 1345, in main
args = cli.prepare_and_parse_args(plugins, cli_args)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/cli.py”, line 1243, in prepare_and_parse_args
_plugins_parsing(helpful, plugins)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/cli.py”, line 1458, in _plugins_parsing
helpful.add_plugin_args(plugins)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/cli.py”, line 840, in add_plugin_args
plugin_ep.plugin_cls.inject_parser_options(parser_or_group, name)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/plugins/common.py”, line 81, in inject_parser_options
return cls.add_parser_arguments(add)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot_apache/configurator.py”, line 159, in add_parser_arguments
add(“handle-modules”, default=cls.OS_DEFAULTS[“handle_modules”],
KeyError: ‘handle_modules’
2018-09-06 12:06:21,643:ERROR:certbot.log:An unexpected error occurred:

My web server is (include version): OpenSuse 42.3

Thanks !


#2

I have the same issue, with the same OS version. Tried removing /opt/eff.org and bootstraping again, but the same error occurs.


#3

Yes, same here. Any idea/support ?


#4

I had the same problem on OpenSuse 42.3.

If you look at the “override_suse.py” file in the directory

“/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot_apache/"

you will see that someone recently modified it to create the “handle_mods” element instead of the “handle_modules” element in the OS_DEFAULTS array.

If you look in the other “override_” files, you will see that they all use the “handle_modules” element name.

I changed “handle_mods=False” to “handle_modules=False” and it now works fine.

Cheers.


Letsencrypt-auto fails
#5

Thanks for the investigation ! It works now :slight_smile:


#6

Someone (one of you?) opened an issue on Certbot’s GitHub.


#7

Thanks for reporting, and thanks to @DLoader for investigating! We’ve put out a point release, 0.27.1, which should fix this issue. Re-run certbot-auto to upgrade :smiley:


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.