ERROR:certbot._internal.log:Email address cannot be empty or null


I am trying to create a certificate with the following command
certbot --nginx --server https://(something)
and although it is was supposed to run ok, i keep getting the error that email cannot be empty.
Any help please?

Welcome @ysintos

What is the value you use for server? Because I can reproduce a problem with a faulty value but not a good one like:


The command is like that

certbot --nginx --server https://xxx/directory

The value is correct because i use it in a number of servers, and it works quite well.
When i run the command for the first time it asked me for an email and i might have entered it wrong.
Where are these values stored, so i can check them if there is a wrong spelling there ?

I am not sure what you are asking. If you are using the production Let's Encrypt system there is no need to specify --server. The test LE system is more easily specified using --test-cert or --staging rather than by server name. See the docs for details

If you have some other CA server, that CA would inform you of the name. And, if not Let's Encrypt that is a certbot question that is better asked on its github (as Certbot and Let's Encrypt are created by different organizations).

We often help with certbot issues here but only when used with Let's Encrypt certs.

1 Like

Have you tried proving an email address?

1 Like

My problem is not the value in the --server option.
My question is this... Is there a conf or an ini file used to save the values entered when i run the certbot command for the first time ?

When certbot is successful, it records all the particular settings in a renewal conf file for that cert.


I strongly suspect that this error message is coming from the Certificate Authority during registration of the ACME account, rather than directly from Certbot.

Posting the full /var/log/letsencrypt/letsencrypt.log file would clarify this either way.

The only place Certbot would take these kinds of flags (like --register-unsafely-without-email or --email) would be in from /etc/letsencrypt/cli.ini.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.