Error after entering certificate issue command

I run a homepage using XAMPP at Ubuntu 20.04. When I used the following command to get the ssl certificate, the following error occurred. I need a cause of this and a solution. I beg you.

My domain is: www.waggle.kr

I ran this command: sudo certbot certonly --webroot -w /opt/lampp/htdocs/w -d www.waggle.kr

It produced this output:
http-01 challenge for www.waggle.kr
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.waggle.kr
    Type: unauthorized
    Detail: (my ip): Invalid response from
    http://www.waggle.kr/.well-known/acme-challenge/(#^%$^$#$#)
    404

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version):

The operating system my web server runs on is (include version): ubuntu 20.04 + XAMPP

My hosting provider, if applicable, is: conoha

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

1 Like

2 posts were merged into an existing topic: How setting up SSL on Xampp (Ubuntu)