I did rename ssl.conf to 0-ssl.conf restarted NetworkManager loads still insecure though. I will look at apache help here

1 Like

Apache is all too forgiving and will try to run at all costs.
Usually allowing too many misconfigurations.
If other sites on this server work securely, then the problem must be within the files serving that particular name [securely].
If all the sites are having the secure problem, then it is a global setting that has gone awry.


I removed all ssls and then ran

apachectl -S

and see

*:443 (/etc/httpd/conf.d/ssl.conf:56)
*:80 is a NameVirtualHost
default server (/etc/httpd/conf.d/00-default.conf:1)

this looks suspect. This is coming from the subdomains on godaddy I set up. Is this
a problem?

Looks like you renamed your default SSL file back then?

The aws name is fine. It is a result of not having a ServerName value in your VirtualHost. In that case Apache uses your default machine name. GoDaddy sometimes uses AWS services (I don't recall exact details at moment).

The good news is your server is responding to HTTPS requests. I get a self-signed cert trying your server. That's fine for a default server but of course not good for an actual domain.

So, try adding one domain and see if that works before proceeding to others.


Correct I renamed default SSL back to 00-default.conf

I removed all SSLs.

re-added ssl for successfully as per

Requesting a certificate for and
Created an SSL vhost at /etc/httpd/conf.d/
Deploying Certificate to VirtualHost /etc/httpd/conf.d/
Deploying Certificate to VirtualHost /etc/httpd/conf.d/
Enhancement redirect was already set.
Enhancement redirect was already set.

Congratulations! You have successfully enabled and

now shows secure from a browser on the self hosted server and my mobile but on ipad shows as insecure. Loads secure on a friend's mobile.

when I run

apachectl -S

I get errors

AH00526: Syntax error on line 27 of /etc/httpd/conf.d/
SSLCertificateFile: file '/etc/letsencrypt/live/' does not exist or is empty

This is line 27

SSLCertificateFile /etc/letsencrypt/live/

in /etc/letsencrypt/life/ I see cert.pem -> ../../archive/

but I do not see a cert.pem -> ../../archive/

Is this the problem? can I rename this file to cert.pem -> ../../archive/

Try restarting your iPad browser. Likely still cached the old one. A good SSL Checker test site shows the cert is fine (link here).

Try it with: sudo apachectl -S

Actually, the SSL conf file is ssl.conf. And, I assume the 00-default.conf is your HTTP (port 80) default but we could look at that. Maybe it has something it should not


You need to run apachectl -S as root, like with sudo.


okay looks good. thanks so much.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.