ERR_SSL_PROTOCOL_ERROR help!

certbot/1.13.0
Apache/2.4.29
domain: onetopstudios.com

I got the certificate using the following command:
certbot .. and number select

After ACMEv1 Brownout, it suddenly doesn't work! It is the same symptom even if you receive a new certificate
I know ACME v2 will be set automatically. is not it?

apache conf:

<VirtualHost *:80>
	ServerName onetopstudios.com
	ServerAlias www.onetopstudios.com
	RewriteEngine on
	RewriteCond %{SERVER_NAME} =onetopstudios.com [OR]
	RewriteCond %{SERVER_NAME} =www.onetopstudios.com
	RewriteRule ^ https://onetopstudios.com%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<VirtualHost *:443>
	ServerName onetopstudios.com
	ServerAlias www.onetopstudios.com

	DocumentRoot /var/www/onetopnews
	
	<Directory /var/www/onetopnews>
		Options FollowSymLinks
		AllowOverride All
		Order allow,deny
		Allow from all
	</Directory>

	DirectoryIndex index.php index.html

	ErrorDocument 404 404.php
	
	SSLCertificateFile /etc/letsencrypt/live/onetopstudios.com/fullchain.pem
	SSLCertificateKeyFile /etc/letsencrypt/live/onetopstudios.com/privkey.pem
	Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
1 Like

Hi @Myodan

please check the fundamental / minimal port 443 configuration

https://httpd.apache.org/docs/2.4/ssl/ssl_howto.html

Looks like you have created that config manual - the most important directive is missing.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.