ERR_CONNECTION_REFUSED on Flask when applying certificate

My domain is:

I ran this command: gunicorn -b --certfile=fullchain.pem --keyfile=privkey.pem main:app

My web server is (include version): Flask (Python 3)

The operating system my web server runs on is (include version): ubuntu 20

My hosting provider, if applicable, is: Vultr

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):1.12.0

Extra note: My api is on a complete different server than my www. The main domain already has ssl (provided by the other hosting service). I now want to pass my api to SSL as well. Problem is, whenever I run gunicorn with the .pem, it outputs that error.

To create the certificate I used: certbot -d --manual --preferred-challenges dns certonly

Please help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.