ERR_CERT_DATE_INVALID after i change hour and timezone on server

My domain is:mobile.cartaounicard.med.br

I ran this command: sudo dpkg-reconfigure tzdata and set to timezone to Sao Paulo.
Because mysql was saving the dates with 3 hours more, so a try change hour in server.

My web server is (include version): DigitalOcean (?)

The operating system my web server runs on is (include version): Ubuntu 16.04

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.00

i run this cmd too: certoboot certificates


Found the following certs:
Certificate name: mobile.cartaounicard.med.br
Domains: mobile.cartaounicard.med.br
expiry Date: 2020-06-14 19:22:35+00:00 (Valid 59 days)
Certificate path: …( i can’t copy paste, so a don’t write all the path)
Private Key path: …

Any tips?

1 Like

You may need to resynchronize your time.
[Using NTP type program or manually.]

Certificates have an end date.
But the also have a start date.
If your current system time is outside that timeframe [between start and stop times], then it will be seen as invalid.
But TIME is relative…
What time one system thinks it is can be different from another system.
That is why we use some sort of global time clock - to keep us all on the same date and time.

For your particular case, you might want to check the DATE on your system.
If the certificate end date is 59 days from now (2020-06-14) then the start date was 31 days ago.
Changing a few hours with a time zone won’t break that.
Your time zone change must have also changed a few months (or years) to make that good cert seem invalid.

2 Likes

I think this is not a problem. You should convert to your timezone when printing, not when saving. (UTC doesn’t change, America/Sao_Paulo might have DST, etc…)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.