Email confirmation?


#1

Hi,

I am having an issue with the initial registration. Everything seemed to be working however I never received the email confirmation and am assuming that at the moment the certificates aren’t valid yet until I confirmed by email. Is there a way to force the email on your side to be resent or should I redo the initial registration with a different email?


#2

There isn’t a specific email confirmation as far as I’m aware.

What script ( and command line ) did you run to obtain the certificates ?


#3

This one…

./letsencrypt-auto --text --agree-tos --email email@domain.com certonly --renew-by-default --webroot --webroot-path /home/cpaneluser/public_html/ -d domain.com -d www.domain.com

This is for a centaus 6.x server with cpanel/whm. I was trying to get a certificate for cpanel.mannydesigns.co and used the below to do so…

./letsencrypt-auto --text --agree-tos --email myemail@me.com certonly --renew-by-default --webroot --webroot-path /home/mannydesigns/public_html/ -d mannydesigns.co -d www.mannydesigns.co


#4

Centos 6 usually has python 2.6 ( and 2.7 is needed) … it should have mentioned that in the information it listed after the command though if that were the case.

There is no email confirmation from that command. If it worked correctly it should have output a certificate for you ( which you will then need to upload into cpanel)

What did the command list afterwards ?

It looks as if 3 certificates have been issued ( 2 for mannydesigns.co and one for mannydesigns.com). Take care as there is a limit of 5 certificates per 7 days per domain.


#5

Ok I knew something was missing. Let me continue and upload them to cpanel. Thanks for your help


#6

Quick question, since I’ve registered mannydesigns.co why does my cpanel.mannydesigns.co shows without a SSL certificate? Do I need to register as something different?


#7

cpanel.mannydesigns.co would be a subdomain of mannydesigns.co so need a new certificate ( or naming on the certificate)

For cpanel though you should use https://www.mannydesigns.co:2083/ which works and shows the correct certificate - and green lock.

On your main site, you include elements via http, so it doesn’t give the green lock.


#8

Ok I see it works.

I also registered mannydesigns.com & sportsadaptes.ca and they don’t show as registered on their site when you visit. Is it possible that it is because wordpress adds www in front?

Again I’m learning how lets encrypt works versus solutions we have used in the past so I appreciate your patience with us learning this process.


#9

mannydesigns.com works fine ( with or without www) as you added both to the cert name. The problem with that is you include items like http://www.mannydesigns.com/wp-content/uploads/2015/09/fullLogo.png as an image on the page. Note that this is via http not https - hence you don’t get a nice green lock. If you modify everything to be included via https then it will all be OK.

The same is the case for https://www.sportsadaptes.ca/


#10

How do I add a subdomain like cpanel.mannydesigns.co? I need to add the suddomain as cpanel does SSL email under this (with our old certificate).


#11

you can just add additional subdomains on the certificate when you create it with the -d option ( the same as you added -d domain.com -d www.domain.com

Having said that, are you sure cpanel uses cpanel.domain.com for email ? it isn’t the usual default. You can just use your domain name ( as they are going to the same IP address) . Installing a cert for email is different than for https though.