Doesn't work "Some challenges have failed."

I deleted my old domain after this, other files anyways here my error:

ertbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: cft-devs.xyz
Type: connection
Detail: 45.142.107.217: Fetching http://cft-devs.xyz/.well-known/acme-challenge/ac4DuKhr0kTa6UUHNLkGU4KEfGnrd9dKvSx080N55no: Connection reset by peer

Hi @TOXIC, and welcome to the LE community forum :slight_smile:

Please show:
apachectl -t -D DUMP_VHOSTS

3 Likes

Your TLS server block is having issues:

curl -Ii http://cft-devs.xyz:443
HTTP/1.1 200 OK
Date: Mon, 31 Oct 2022 02:12:39 GMT
Server: Apache/2.4.38 (Debian)
Content-Type: text/html;charset=UTF-8

curl -Ii https://cft-devs.xyz
curl: (35) error:1408F10B:SSL routines:ssl3_get_record:wrong version number
4 Likes

Prints this:

VirtualHost configuration:
*:80                   cft-devs.xyz (/etc/apache2/sites-enabled/000-default.conf:1)

We should have a look at the file:
/etc/apache2/sites-enabled/000-default.conf

and also the output of:
netstat -pant | grep -i listen | grep -Ei 'apache|http'

3 Likes
<VirtualHost *:80>
	# The ServerName directive sets the request scheme, hostname and port that
	# the server uses to identify itself. This is used when creating
	# redirection URLs. In the context of virtual hosts, the ServerName
	# specifies what hostname must appear in the request's Host: header to
	# match this virtual host. For the default virtual host (this file) this
	# value is not decisive as it is used as a last resort host regardless.
	# However, you must set it for any further virtual host explicitly.
	#ServerName www.example.com

	ServerAdmin webmaster@localhost
	DocumentRoot /var/www/html

	# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
	# error, crit, alert, emerg.
	# It is also possible to configure the loglevel for particular
	# modules, e.g.
	#LogLevel info ssl:warn

	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

	# For most configuration files from conf-available/, which are
	# enabled or disabled at a global level, it is possible to
	# include a line for only one particular virtual host. For example the
	# following line enables the CGI configuration for this host only
	# after it has been globally disabled with "a2disconf".
	#Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
tcp6       0      0 :::80                   :::*                    LISTEN      517/apache2

I runned command with -v flag now it worked