.digital domain unable to get certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: avalon.digital

I ran this command: ’ certbot --authenticator webroot --webroot-path ‘/var/www/html/’ --installer apache -d ‘avalon.digit’ ’

It produced this output: ’ Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer apache
Obtaining a new certificate
An unexpected error occurred:
The request message was malformed :: Error creating new authz :: Name does not end in a public suffix
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version):ubuntu 16.04LTS

The operating system my web server runs on is (include version): apache2

My hosting provider, if applicable, is: Vultr

I can login to a root shell on my machine (yes or no, or I don’t know): Yes, via SSH.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, if you mean wordpress conrol panel

.digital is definitely on the PSL.

The way you have run the command seems to have cut off some characters :slight_smile: :

-d ‘avalon.digit’

What do you mean?
BTW, how can I insert code in here?

Post formatting is using Markdown.

You mistyped avalon.digit instead of avalon.digital in your Certbot command:

I ran this command: ’ certbot --authenticator webroot --webroot-path ‘/var/www/html/’ --installer apache -d ‘avalon.digit’ ’

1 Like

Sorry for that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.