Cpanel reseller letsencrypt not enabled - manual set up issues

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: yaadev.com

I ran this command: getssl yaadev.com

It produced this output: yaadev.com: Certificate on remote domain does not match, ignoring remote certificate

My web server is (include version): httpd (2.4.29 (cPanel))

The operating system my web server runs on is (include version): CLOUDLINUX 6.9 standard

My hosting provider, if applicable, is: Greengeeks.com

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cpanel reseller

I have successfully manually installed a certificate using dns verification via sslforfree.com for one of the domains. I have a dedicated IP for my reseller account that is shared by 33 domains.

The certificates are created on my local machine successfully but I run into the issue when getssl tries to copy them and install on the server. I have copied the cpanel additional script to the server and set.
RELOAD_CMD="${HOME}/cpanel_cert_upload yaadev.com"

I do not know where to go next…

https://www.greengeeks.com/kb/?s=ssl

sorry I was not clear, it is a reseller account with 35 individual accounts under it with one domain each. The reseller account has a dedicated IP that is shared by the individual accounts. Each account has its own cpanel interface and home directory.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.