CPANEL Install failure on SiteGround


#1

Using CPANEL I tried to install Let’s Encrypt on Vivaliti.com and got the following error message.

Is this a propagation issue? Or am I missing some info in my header.php file?

FYI - my DNS is pointed at GoDaddy but I have created an A record to point to the site’s unique ip 109.73.230.100

Domain: www.vivaliti.com
Type: unauthorized
Detail: Invalid response from http://www.vivaliti.com/.well-known/acme-challenge/et2Ax7hqXkcCxbLj9v4YYOWwWHvLFwoq6fJSRrmBLCE: "

404 Not Found

404 Not Found


"

#2

Is this using AutoSSL in cpanel ? or what command did you run ?


#3

Hi there. Thanks for the speedy reply. I am using the Let’s Encrypt auto install found in the security section of cpanel. It is a orange a blue lock icon with Let’s Encrypt text below.


#4

I’m assuming this looks like - https://letsencrypt-for-cpanel.com/docs/for-users/user-guide/

This isn’t a plugin I’ve used ( there is a different one which is the official cpanel one ). So you may need to talk to your host in order to get the detailed logs

You can test the basics by creating the directory structure .well-known/acme-challenge/ within the webroot directory of your domain, and then adding a text file called “test” in that with contents “ok”.

Then can you reach http://www.vivaliti.com/.well-known/acme-challenge/test in your browser. The error you are getting at the moment is essentially a file here can’t be checked - hence worth the manual test.


#5

Thanks for the quick reply. we did look at that plugin and I think it is a viable option. The only drawback I found was that it required renewal every three months.

Here is what finally worked for us. It ended up being a SG server configuration issue.

From SG Support:
I had to regenerate the nginx vhosts used by the application in order to install the Let’s Encrypt SSL certificate. I have seen such issues before as the nginx is not able to find the folder and the vhosts had to be regenerated in order to resolve the issue.

We also found this code…
I think i found another solution… adding this to the .htaccess file RewriteRule “^.well-known/acme-challenge” - [L]

Hope this helps you!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.