Could not load file or assembly 'Microsoft.AspNet.TelemetryCorrelation', when requesting new certificate for LetsEncrypt

My domain is:

https://crt.sh/?q=karcherutleie.no

I ran this command:
Issued new certificate through the azure extension
It produced this output:

The Lets Encrypt ACME server was probably unable to reach URL view error report from Lets Encrypt at https://acme-staging.api.letsencrypt.org/acme/authz-v3/4982785 for more information

My web server is (include version):
Azure Web
The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
Microsoft
I can login to a root shell on my machine (yes or no, or I don’t know):
I dont know
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Azure Portal
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Azure Let’s Encrypt

Version 0.9.6

I’m trying my luck here since bad reseption at stackoverflow (https://stackoverflow.com/questions/57560478/could-not-load-file-or-assembly-microsoft-aspnet-telemetrycorrelation-when-re)

Basicly, the renew of certificate have worked fine for 2 years, then suddenly stopped working,
Things I have tried:

  • Reinstall all dependencies in .net, and made sure everything is up to date
  • Thought it had something to do with not being able to access the server since it automatically redirects to HTTPS, and the request is http. Turned off force https .
  • Reinstalling letsEncrypt extension and double checked the keys are correct

Hi @fredrikzkl

check the url manual. Then you see the error:

https://acme-staging.api.letsencrypt.org/acme/authz-v3/4982785

Checking the /.well-known/acme-challenge url:

https://karcherutleie.no/.well-known/acme-challenge/Pfr4DMPTigFo314TWKQN4zifBioKuo93Ub5ZNKcwAn4

there is a debug output.

Server Error in '/.well-known' Application.

Could not load file or assembly 'Microsoft.AspNet.TelemetryCorrelation' or one of its dependencies. The system cannot find the file specified.

So your local .NET installation is incomplete.

Or that Azure Let's Encrypt requires a web.config with the assembly addresses.

PS: No, it's not that Azure Let's Encrypt tool. It's your server configuration that is incomplete. Fetching an url of your server -> crash.

It has worked properly for 2 years straight now, so weird the installation suddenly was insufficient. Do you recommend “reinstalling” the whole thing on the server side?

Then you have changed something -> find that and fix it. Perhaps installed something new that doesn't work with the /.well-known/ subdirectory.

That's always wrong. Same action -> same problem -> nothing solved. You have to find the error instead of repeating the error.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.