Could not find cert file - Debug output included


#1

Please fill out the fields below so we can help you better.

Debug output:

Traceback (most recent call last):
File “/opt/letsencrypt/venv/bin/letsencrypt”, line 9, in
load_entry_point(‘letsencrypt==0.2.0.dev0’, ‘console_scripts’, ‘letsencrypt’)()
File “/opt/letsencrypt/src/letsencrypt/cli.py”, line 1398, in main
return args.func(args, config, plugins)
File “/opt/letsencrypt/src/letsencrypt/cli.py”, line 600, in obtain_cert
_auth_from_domains(le_client, config, domains)
File “/opt/letsencrypt/src/letsencrypt/cli.py”, line 381, in _auth_from_domains
action, lineage = _treat_as_renewal(config, domains)
File “/opt/letsencrypt/src/letsencrypt/cli.py”, line 237, in _treat_as_renewal
ident_names_cert, subset_names_cert = _find_duplicative_certs(config, domains)
File “/opt/letsencrypt/src/letsencrypt/cli.py”, line 206, in _find_duplicative_certs
candidate_names = set(candidate_lineage.names())
File “/opt/letsencrypt/src/letsencrypt/storage.py”, line 461, in names
raise errors.CertStorageError(“could not find cert file”)
CertStorageError: could not find cert file

2016-07-21 13:55:58,877:INFO:letsencrypt.cli:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2016-07-21 13:55:59,073:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
could not find cert file

My operating system is (include version):
Ubuntu 14

My web server is (include version):
Custom

My hosting provider, if applicable, is:
Custom

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


#2

Also it appears to be looking for the cert of a domain which is not part of the request.

2016-07-21 14:04:30,134:DEBUG:letsencrypt.storage:Expected symlink /etc/letsencrypt/live/notdomain_i_am_working_with.com/cert.pem for cert does not exist.
2016-07-21 14:04:30,135:DEBUG:letsencrypt.cli:Exiting abnormally:


#3

Nvm solved,

I removed the .conf of the troublesome domain and it worked again. Confusing since a domain i was not working with could case this failure.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.