Constantly ratelimited, have not used lets encrypt in over 2 months

My domain is: merith.tk

I ran this command: Dont know, using Caddyserver, which automatically aquires this

It produced this output:

Jan 21 20:29:27 merith-tk caddy[9457]: failed to obtain certificate: acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:rateLimited :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/, url:

My web server is (include version): Caddyserver (cannot check ver at the moment)

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Self Hosted

I can login to a root shell on my machine (yes or no, or I don’t know): Yes, but not at the moment, in about 5-6 hours from the posting this message,

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Unknown using Caddyserver

EDIT: A little more context to the situation, i was using cloudflare strict TLS which is why was not using lets encrypt, the problem is i am still getting ratelimited for litterally no reason because im moving from strict TLS back to standard encryption

1 Like

:wave: Hi @Merith-TK, welcome to the community forum :wave:

I can confirm that you’re being rate limited for the reason specified in the message: too many failed validation attempts:

There is a Failed Validation limit of 5 failures per account, per hostname, per hour. This limit is higher on our staging environment, so you can use that environment to debug connectivity problems.

Your Caddy installation tried, and failed, to validate an HTTP-01 challenge 5 times within the period between 22/01/2020 03:02:11 UTC and 22/01/2020 03:02:48 UTC for a sub-domain of merith.tk.

I recommend you switch your configuration to use the staging environment while you troubleshoot the problem. It would also be worthwhile to see why your Caddy logs don’t include the failed authorization attempts that are the cause of your rate limiting problem.

As mentioned in the rate limit docs you can also try again after one hour.

1 Like

Hi @Merith-TK

checking your domain that can’t work - https://check-your-website.server-daten.de/?q=merith.tk

You use Cloudflare, there are redirects http -> https.

Your http works partial, your https has only timeouts. So it’s impossible that Letsencrypt checks your validation file.

Isn’t it possible that you use the Cloudflare integrated solution?

If not, first deactivate Cloudflare, fix your timeout, create a certificate, then activate Cloudflare again.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.